This question already has an answer here:

My ubuntu is 14.04, the default gcc and g++ is 4.8, I installed gcc and g++ 4.4 manually, so how can I specify the older version of gcc to call when I compile a program?

marked as duplicate by muru, Sylvain Pineau, mikewhatever, karel, αғsнιη Oct 15 '14 at 6:29

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • How did you install it? Usually you just call gcc-4.4, gcc-4.6, etc., but depending on how you installed, that may not work. – muru Oct 14 '14 at 1:40
  • I installed like this: sudo apt-get install gcc-4.4 g++4.4, so can I specify which gcc to use in make? – Dongwei Wang Oct 14 '14 at 1:52
  • because when I make cuda 4.0 samples, this was always an error says: unsupported GNU version! gcc 4.5 and up are not supported! – Dongwei Wang Oct 14 '14 at 1:54
  • I'd say you might be asking for problems as some of the bindings generated on the older versions of the compiler might not be compatible with the later operating system. So things using shared object libraries might have difficulty. Why not just use the latest version? – mdpc Oct 14 '14 at 2:09

Browse other questions tagged or ask your own question.