1

So I installed linux (ubuntu) yesterday on a fresh hdd with a disk. It worked fine till today when it froze after I had had it in sleep mode and I had to turn it off and on again to be greeted with a message

error: file '/boot/grub/i386-pc/normal.mod' not found. entering rescue mode... 
grub rescue>

I am not dual booting and I dont know exactly what to do. I'm relatively new to ubuntu and linux in general. My pc is a dell latitude laptop. Don't know if I should just convert back to windows...

  • What is your BIOS mode? is legacy or UEFI mode? – αғsнιη Oct 14 '14 at 4:32
  • it was legacy but I switched it to UEFI and still had problems. I searched a couple of tutorials to fix the problem some involving me to put in my disc and going into terminal and doing some updates on grub. I eventually caved seeing as how I need a working computer and installed windows – Jose B Oct 14 '14 at 5:30
  • oh i see. So I have a hdd of 1tb so if i has just allocated memory to a /boot it would have worked perfectly fine. So if i do get it working how would I do that now? could i just make another parition to make that? I only installed / and /root – Jose B Oct 17 '14 at 3:13
  • Follow this askubuntu.com/a/528955/283843 – αғsнιη Oct 17 '14 at 5:58
1

Run this command in a terminal window (press Ctrl+Alt+F1 key combination at login prompt if needed to enter text-mode Ubuntu/console):

    sudo update-grub

Reboot and see what next. If you still have problems after reboot, visit this page where you'll find some official guide for Ubuntu repair with the installation media. Make sure you still have Ubuntu installation DVD or the Live USB pendrive from where you installed Ubuntu.

  • Thanks hopefully this works for someone else since It didn't for me. I saw this response way after I had already installed windows. hopefully in the future if I ever have problems I can look back on this post and see a way to fix it. But for now i'm too inexperienced for linux seeing as i'm no coder (and it involved a lot of code for my tastes) thank you for responding however. – Jose B Oct 14 '14 at 5:32
  • Your HDD is probably listed as /dev/sda, and your root partition is probably /dev/sda1/. Once you have this info (to make sure open Gparted after you boot the Live DVD) you can run those commands from the official guide as they are, just copy-paste them in a terminal window, and replace X or XY with /dev/sda/, or /dev/sda1/ where required. When it comes to reinstalling grub, make sure you choose /dev/sda/ - the entire HDD - and not /dev/sda1/ which is your root partition. You can save that recovery guide as a simple html page, and use it after booting the Live DVD. – Taz D. Oct 14 '14 at 7:02
  • ok so i reinstalled it but it didn't work still even after I had installed it again. I'm still having issues with the normal.mod dont know what to do i'm still stuck on the same page. I tried your way but still nothing I didn't even include /dev/sda1 and i just tried to do that old process all over again. One thing I noticed is that /dev/sda is locked so I can't modify it. Can you help me again?? – Jose B Oct 16 '14 at 4:10
  • Go to this page and choose either 32bit iso image (if you run Ubuntu 32bit) or the other one, boot-repair-disk-64bit.iso, for Ubuntu 64bit. Burn image on a CD or write it on USB pendrive with Unetbootin. Boot the CD/USB pendrive and choose Recommended Repair. After you finished, reboot and hopefully youll be ok. More info on this page. If it works fine, run sudo update-grub in Ubuntu, to be able to boot Windows too. – Taz D. Oct 16 '14 at 5:08
  • is it possible to get that file as a torrent file? – Jose B Oct 17 '14 at 3:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.