0

I've just bought a wireless combo keyboard + mouse, specifically Logitech mk270. Everything is working out-of-the-box, except for some multimedia keys, specifically the ones for the audio and the home one.

I've tried to configure it in the shortcut keyboard settings of ubuntu, when I assign volume mute to the proper key ubuntu indeed recognize that key and actually writes "Audio Mute" as key name. Same with volume up, volume down and Play/Pause.

Also, doing a the "System testing" ubuntu tool, the test says ok when I press those requested keys, so it's actually received by ubuntu.

Another interesting thing is that the home key is assigned by me in the shortcuts to open mi home folder, but it doesn't, it actually changes my current web page with my home-browser page. It looks like the keyboard doesn't care about what the system has defined to do with that keys and they do what the keyboard has defined them to do.

More info: assigning another key, like "Pause / Inter" for "Play/Pause" action or "Bloq Scroll" for "Mute Audio" action indeed work as expected.

EDIT: Curiously, same keyboard and mouse in another machine with the same system configuration: ubuntu 14.04 64 bits, it's working out-of-the-box...what's going on?

EXTRA: nano receiver came with this combo; but I'm realizing it's not compatible with Solaar package (my usb id is this: 046d:c534, not supported by Solaar) . Any work around for this?

1

I managed to get it working!

This was about a confusing bug of Ubuntu. The keys were marked as "Audio Mute" or "Audio Play" in the unity keyboard settings correctly, but underneath it was recording the same values for the gnome dconf entries related to this keybindings.

In summary, I've had to open the dconf-editor and follow the instructions described here: How can I restore default keyboard shortcuts? in order to reset the default values for the keybindings, which were not "AudioPlay" but "XF86AudioPlay" and so on.

This is an annoying bug and difficult to debug for common users, but finally you understand what's going on it's easy to fix.
Just reset the values to default with the dconf-editor tool and if you want to change any behaviour of any of these multimedia keys, get the X86 value from a tool like xev or find out yourself which value is, then look for the action you want to change and change its value for the X86 one you have got and it should be working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.