Multitouch seems to be working fine on Chromium out of the box, but not on Firefox. On Chromium, dragging a finger up or down the screen scrolls the screen as expected, but on Firefox, that gesture seems to be highlighting text. How can I get Firefox to play nice with multitouch gestures?

I'm running Ubuntu 14.04 on a Lenovo Yoga 2 11" convertible laptop.

Edit: I read the page here which says that touch capability is present but disabled in FF. But enabling them and restarting doesn't seem to have any effect--dragging one's finger across the screen still only selects text.

  • I think is is more of a Ubuntu problem, as it sees touchscreens as an absolute pointer device. Have an upvote though.
    – Kaz Wolfe
    Oct 22, 2014 at 17:27
  • @Whaaaaaat, I see the same problems with Firefox on Fedora running GNOME 3.14, which has the best multitouch capability I've seen yet, so I don't think it's Ubuntu that has the problem.
    – Jonathan
    Oct 22, 2014 at 20:23
  • Have you tried touchegg + Touchegg-gce? And, at east in chromium it is already possible, with "chromium-browser --touch-events=enabled" Oct 26, 2014 at 1:21
  • Some extensions mentioned here may help
    – Wilf
    Oct 26, 2014 at 17:53
  • 2
    Does this answer your question? How to enable touchscreen scrolling in FireFox? Jan 20, 2023 at 15:22

6 Answers 6


On Xubuntu 16.04 with Firefox 50, I got it working by enabling e10s and setting the env-var MOZ_USE_XINPUT2=1. In detail:

  1. Enable e10s/Multiprocess. If you're running Firefox 57 or higher, it should be enabled already. Otherwise, you may have to disable a bunch of addons, and possibly force enable it.

    • Use https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/ to check which addons are incompatible with e10s, although simply having only-marked-as-compatible addons is not enough in FF50 to get e10s switched on, you may have to force-enable it anyway (in FF50, only certain whitelisted addons are allowed with e10s by default – later versions will enable e10s as long as all addons are compatible).
    • You can check in about:support if Multiprocess is on. If you need to force-enable, just open about:config, right-click and enter a new boolean value with the name browser.tabs.remote.force-enable; then restart FF and check about:support again.
  2. Exit FF, and start it from the command-line with MOZ_USE_XINPUT2=1 /usr/bin/firefox.

Now you can test https://www.paulirish.com/demo/multi and scroll with one finger.

Source: https://support.mozilla.org/en-US/questions/1091627

  • 1
    This worked for me on Ubuntu 16.04, v50. Feels much more natural than the Pan And Drag extension! (It uses Asynchronous Pan and Zoom, or APZ, which runs the scroll on a separate thread, and it's got more of an elastic / smooth scroll feel) Jan 13, 2017 at 0:50
  • Worked nicely for me. I have to say though, the pinch-to-zoom is way less slick than on chromium. Dec 6, 2017 at 7:09
  • Worked for me too! Ubuntu 18.04, Firefox 69 and don't work out of the box... Oct 21, 2019 at 16:59

Firefox doesn't yet support multitouch on X11/Linux. At present, work is underway on upgrading from GTK+ 2 to GTK+ 3 which I believe has landed in Nightly and Aurora/Developer Edition. There's a bug tracking the GTK upgrade as well as a bug for touch event support. The overall bug for multitouch support on Linux appears to be 711711 which depends on the bugs mentioned above.


"Grab and drag" extension for Firefox did the trick for me, allowing at least for scrolling without selecting text. Gestures, however, do not seem to work.


I believe this is an issue with Firefox itself, as it does it on various OS's, and on various hardware. I know how to get it work on a MacBook multi-touch touchpad running Ubuntu, so I'll show you how to do it there, and you should be able to get it to work on your touch screen as well, as it's a setting within Firefox, not the system.

Ok, open Firefox, and enter about:config in the address bar, then in the filter box, put browser.gesture, that will bring up all the touch gestures for Firefox. Once you have the touch settings showing, look for browser.gesture.pinch.in and set the value to cmd_fullZoomReduce, that should give you the zoom out, and to get the zoom in, look for browser.gesture.pinch.out and set that value to cmd_fullZoomEnlarge. Once you have those values set, there are 2 more settings you have to change. The next one you want to look for is browser.gesture.pinch.latched by default it's set to true you want to change that to false, then go to browser.gesture.pinch.threshold, which is set to 150 by default, you want to change that value to 10.

That is how I got all the multi-touch features working for me, I hope it works for you as well, good luck.

  • 4
    This doesn't work for me--dragging my finger across the page still doesn't move the page like it does in Chromium, it still selects text. Pinching and zooming also just select text. So the problem seems to be that Firefox just isn't recognizing touch screen events as touch events--it's seeing them as mouse events, maybe?
    – Jonathan
    Oct 26, 2014 at 15:07
  • Did not work for me Jan 11, 2020 at 6:20

In the Firefox version in Ubuntu 18.04 it works out of the box:

  • pinch-to-zoom with two fingers (a bit slow and unresponsive and you better use fingers of both hands)
  • scrolling with two-finger-tab and swipe up and down (also a bit unresponsive)
  • three-finger-tap gets the menu
  • dragging one's finger across the screen selects text

There seems no option to copy the selected text, but you can use Shift+F10 to get the menu and select copy there


Only add this line at end of ~/.profile and restart your session.

export MOZ_USE_XINPUT2=1
  • Welcome to AskUbuntu! You are probably being down-voted because your answer is duplicative of the more detailed answer above: askubuntu.com/a/868076/89175 To avoid this, please review other answers to the questions before posting your own. Or, if there is something wrong with the other answer, please explain so that other users can understand why your answer appears duplicative, but isn't.
    – PatKilg
    Dec 4, 2019 at 21:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .