6

I had a severe problem with GPU temperature in 12.04 and even later, and even if that seems gone in 14.04, I want to keep an eye on my GPU.

Is there a program that would display that, in the xfce-panel or otherwise?


EDIT:

After installing lm-sensors and the Xfce panel Sensors Plugin, I can see some temperatures

enter image description here

but not the GPU. I use the Ubuntu radeon driver.

enter image description here

Also, I have installed psensor: but no GPU

enter image description here

Also, running sensors in Terminal that info is not available:

enter image description here

EDIT2:

At this Psensor page it reads: When the OpenSource ATI driver is used, the monitoring information is available throw lm-sensors ....

I have installed lm-sensors and following this advice I ran sensors-detect and answered yes to all questions there. In Psensor window now there is a new entry, and it's for radeon, but it's always zero.

enter image description here

Editing the names so as to display the chip name, it looks like so:

enter image description here

sensors command gives the same info as above.

EDIT3

Also:

~$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
[sudo] password for cip: 
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

EDIT4:

~$ xrandr --setprovideroffloadsink 0x6c 0x44 X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  140 (RANDR)
  Minor opcode of failed request:  34 ()
  Value in failed request:  0x6c
  Serial number of failed request:  17
  Current serial number in output stream:  18
5
  • 1
    What is the output of sudo cat /sys/kernel/debug/vgaswitcheroo/switch?
    – Rmano
    Oct 13, 2014 at 12:34
  • @Rmano - edited to add output
    – user47206
    Oct 13, 2014 at 12:37
  • 1
    As you can see the ATI card is off (status DynOff) --- this is why you have a 0 in the reading. I will edit the answer to show how to switch it on.
    – Rmano
    Oct 13, 2014 at 15:48
  • 1
    @Rmano - I think I got it.
    – user47206
    Oct 13, 2014 at 16:03
  • @Rmano - added that. sorry for delay
    – user47206
    Oct 13, 2014 at 16:37

3 Answers 3

6

I use xfce4-sensors-plugin:

enter image description here

It needs lm-sensors installed and configured, and it is in the standard (universe) repository.

The ATI sensor (when used with the radeon open source driver) should be called something like radeon-pci-0100 --- Notice however that with recent kernels the card is kept off when not used, so the sensor is not read in that conditions --- see https://askubuntu.com/a/469439/16395

You can check if the sensors are working activating the offloading as explained in this post: http://xpressrazor.wordpress.com/2013/10/08/enable-and-use-open-source-radeon-drivers-in-a-muxless-hybrid-graphics-intelamd-setup/:

  1. List the graphic providers:

    xrandr --listproviders
    

    make a note of the id hexadecimal codes

  2. Activate them:

    xrandr --setprovideroffloadsink 0x53 0x79 
    

    (you have to substitute the codes of the Intel and ATI providers, in that order)

  3. Open a terminal window and run

    DRI_PRIME=1 glxgears -info 
    

Now using sensors in another window you should see the temperature reading of the radeon card going up.

9
  • i have that and see what you displayed in image. but is that the gpu? under sensors type radeon there is nothing for me. maybe because of not using the ATI driver?
    – user47206
    Oct 13, 2014 at 9:57
  • No, this is not the GPU. Now I do not have the ATI laptop with me (the screenshot id from one with an intel graphics). Should be called radeon-pci-something, as askubuntu.com/a/469439/16395
    – Rmano
    Oct 13, 2014 at 10:01
  • 1
    I can read it with the radeon driver; I will check on the laptop this evening at home but the linked answer was copy-and-pasted from there and I have no proprietary drivers installed. You should check that one --- maybe the radeon is off and nothing is shown; try to type sensors in the command line
    – Rmano
    Oct 13, 2014 at 10:11
  • 1
    You have to adapt the 0x53 0x79 to what the previous command gave you --- they will differ from machine to machine. But if it works that means that it is enabled by default (as should be).
    – Rmano
    Oct 13, 2014 at 16:15
  • 1
    "Notice however that with recent kernels the card is kept off when not used, so the sensor is not read in that conditions" this single sentence fixed my problem.
    – Tooniis
    Nov 10, 2017 at 9:37
1

After doing all those actions that are presented in the question and also after updating Psensor to version 1.1.2 the Radeon temperature appeared there after reboot.

sudo add-apt-repository ppa:jfi/psensor-unstable
sudo apt-get update
sudo apt-get install psensor

More here: Psensor Updated With Option To Display Temperature Sensors On The Panel.

enter image description here

UPDATE:

The radeon info appeared in Psensor only after reboot if set to launch on startup. Also, it is odd that if Psensor is closed and restarted without reboot, the radeon entry is absent again.

In fact the ATI card is not working at that moment as this answer explains: New kernel 3.13 has an advanced dynamic power management of the ATI card with the radeon driver. In normal conditions the ATI discrete is off.

Both Psensor and Xfce Sensor plugin will display the radeon temperature at startup if they are open but if they are restarted the entry will be missing in Psensor, will be zero in the Xfce panel plugin and will be N/A when running sensors.

To test this, and start the ATI card, that answer says to run glxgears:

DRI_PRIME=1 glxgears -info

enter image description here

What happens then is that the Xfce panel plugin will show the GPU temperature, while psensor will not until restarted. sensors command will display the temperature of the ATI card.

If glxgears is shut down, the discrete card will stop. Then, Psensor will continue to show the last GPU temperature until restarted. The panel plugin too, but not for long. In its properties, radeon temp is already zero, uncheck and recheck to refresh.

1
  • note that you should not left click the panel icon but right -> settings instead. the former is buggy.
    – phil294
    Mar 7, 2017 at 12:17
0

Wrote a small python script which could be used in your XFCE panel to monitor the GPU temp, Utilization, Fan speed, Memory and Power based on gpustat https://github.com/wookayin/gpustat.

You can check it out in my repository

https://github.com/Paptop/XfceGpuPanelMonitor

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy