4

In Ubuntu 14.04 Server I've got a share mounting correctly with the following command:

sudo mount -a 192.168.10.5:/mnt/sf_nas/movies /mnt/movies

However, when I add the below line to /etc/fstab and reboot, the share is not mounted:

192.168.10.5:/mnt/sf_nas/movies /mnt/moviesnfs auto,noatime,nolock,bg,nfsvers=4,intr,tcp,actimeo=1800 0 0

Can anyone tell me what I'm missing here? Thanks in advance!

  • 2
    Did you forget to add a space before nfs or is that a typo? And is your NFS server running v4 or v3? – muru Oct 12 '14 at 21:05
  • 1
    Yes, the missing space was a typo but it never occurred to me to check the NFS version. The server is a FreeNAS box which, as I just found out, runs version 3. Changing the version in fstab fixed it. Thanks a bunch! – Sean Cunningham Oct 12 '14 at 21:27
5

Setting nfsvers=4 would cause the mount to fail if your NFS service is version 3. You need to set nfsvers=3, or not set it at all (from man nfs):

nfsvers=n      The  NFS  protocol  version  number  used to contact the
               server's NFS service.  If the server  does  not  support
               the requested version, the mount request fails.  If this
               option  is  not  specified,  the  client  negotiates   a
               suitable  version  with  the  server,  trying  version 4
               first, version 3 second, and version 2 last.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.