0

I have a problem booting up my fresh Ubuntu install. I messed around with this for a few days now, and can't figure it out or find a solution for it. Most likely it's my nvidia optimus driver problem but here's the run down:

When I try Ubuntu on my laptop, it works flawlessly. Doesn't refuse to boot. Then, I install the Ubuntu from a bootable usb I created. I tried reinstalling the usb multiple times and don't think that's the problem. Install goes well and asks me to restart the computer. That's when I run into this issue.

The computer goes through the bios screen (press f2 for BIOS... etc...). Screen goes black, then dimly lights up, then goes black and keeps cycling these two displays.

Now. I can get into Ubuntu if I press ESC a few times so it skips the boot selection (blue) screen, then I have to run my hand across the keyboard multiple time so that a blinking cursor appears and that's when I know after a few seconds the Ubuntu login screen will appear. Then Ubuntu works fine after that.

In the boot selection(after a single ESC press) there's two relevant options "ubuntu" and "1. my ssd drive". If i select 'ubuntu' the screen starts cycling the black and dimly lit phase. If I select the other option screen is perpetually dimly lit and takes no inputs.

I'm at a loss, and need help solving this issue :( ps. I'm a fairly new linex user.

  • When you restart the machine after install, do you still have the usb stick plugged in? If so, shut down machine and take out usb stick before bootup. Also, I'm confused about your reference to "blue" screen and bios screen after restart. Are you not seeing purple grub bootloader? – 5th Wheel Oct 12 '14 at 21:20
  • I take the stick out. But I tried leaving it, it doesn't help either way. Rebooted the system with some difficulty to get you the answer. After the ESC I see a "Boot Menu" with the following choices "1. ubuntu" "2. SATA HDD:: Samsung SSD 840 Series" "3. SATA CD:: blah blah". If I hold shift to enter grub (?) nothing happens, just keeps blinking. – Drei3000 Oct 12 '14 at 21:45
  • Ok, I'm just trying to figure out what is going on when you first boot up machine. It seems like it's a failed installation. That's why I was asking if you take out usb stick, can you still get to Ubuntu after all the key strokes/workaround. When you boot up machine, you should see something like this (not text specific) ubuntulinux.ru/wp-content/uploads/2012/05/grub_menu.jpg This is a grub menu( image)Ok, looks like Xieerqi figured it out for ya. – 5th Wheel Oct 12 '14 at 22:05
0

Try taking a look at /etc/default/grub file. Open command line (Ctrl + Alt +T or Ctrl +Alt + F1), and type cat /etc/default/grub . Specifically, at this portion:

enter image description here

Try altering GRUB_DEFAULT , GRUB_HIDDEN_TIMEOUT, GRUB_TIMEOUT, GRUB_CMDLINE_LINUX_DEFAULT just like mine.

Also, /var/log folder has quite a few logs that can help you troubleshoot issues. Specifically in this case you're interested in dmesg file and boot.log file. I'd suggest you read those and/or attach to your question. To do that you can do cat /var/log/dmesg > ~/dmesg_log.txt , which will output a copy of dmesg log into your home directory. Same thing with other logs

  • My grub was similar to yours exept GRUB_TIMEOUT, mine was 10. Changed to 5, but had no effect on startup, here are the logs: justpaste.it/hjnt – Drei3000 Oct 12 '14 at 21:56
  • In your dmesg log there is a line [ 2.740866] nvidia: module verification failed: signature and/or required key missing - tainting kernel . So yeah, seems like nvidia issue. Read through this page : help.ubuntu.com/community/BinaryDriverHowto/Nvidia . Especially refer to Boot Splash Screen Issues part – Sergiy Kolodyazhnyy Oct 12 '14 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.