1

For the past couple of days I was experimenting with Ubuntu. I am running Ubuntu 14 (BIOS) on a Dell xps 15Z. I used a USB drive to install ubuntu on this system (HP formatting tool & YUMI) however since a failed a try in installing WIN 7 OEM via usb, this system does not boot with live USB anymore: " Operating system not found."

I tried to remake the usb via another laptop running windows, the usb works on that laptop but not on the this one running ubuntu; Then I made a live usb using "Startup Disk Creator", which still does not work on this laptop.

Any ideas what is the cause and how I can fix it?

p.s: I do not have CD/DVD drive on this laptop.

Thanks in advance

  • Looks like Your BIOS settings are not set to boot from USB stick (Boot from other devices). Anyway I would try pressing F12 after power on (F12 is common key for Boot menu) and pointing at Your USB drive (must be shown there to be booted). Because Operating system not found. rather says about HDD not the USB. – Esamo Oct 12 '14 at 17:58
  • USB is the first device for booting, I have not changed that. The HDD is working fine, I have a ubuntu installed as I said which is working. – Koosha Oct 12 '14 at 18:09
  • So USB works for other comp but not with the installed & working Ubuntu? And nothing wrong in BIOS? Must be matrix error. Or compatibility of USB's boot sector. – Esamo Oct 12 '14 at 18:13
  • Dell xps15z bios is limited, you can only do basic stuff such as changing the boot sequence or enabling/disabling external usb - not changing the boot type. The bios setting have not changed since the last successful boot via usb. So, how can I make sure the usb's boot sector is compatible with this system as well? I tried to make a usb boot from the ubuntu, which fails to work on this system, but boots up my other laptop! – Koosha Oct 12 '14 at 18:18
  • And You can not choose the boot device for a single time? Otherwise that could point out if Your USB informs about boot option. On the internet I've found a case related to me a while ago "Access to the BIOS, and change disk support from UEFI to LEGACY , and then your USB-stick will be recognized". – Esamo Oct 12 '14 at 18:28
0

If you're using the same USB you used to install Windows with to try and boot Ubuntu Live CD are you sure you formatted it before burning the ISO on it?

  • I first made the usb on another windows running machine, using YUMI multiboot creator, I had bootrepair, ubuntu, windows and couple of other tools on the usb. on the second and third time I made a live usb on windows and on Ubuntu, I formatted it using HP Formatting tool and Startup Disk creator respectively. Anyway, as I said, the usb is working fine on another laptop while booting. It is only this system running ubuntu which can not use the usb as a boot anymore. – Koosha Oct 12 '14 at 17:52
  • Oh I misunderstood that. – Daniel Oct 12 '14 at 17:54
  • You didn't change anything BIOS? – Daniel Oct 12 '14 at 17:54
  • It's the "Operating system not found." line that makes me think it's related to the way you setup the USB. I had a similar error when I was booting a Mac using a Windows 7 USB. And as it turns out the problem was I had put some data on the USB in a directory after creating the bootable USB. And somehow that simple thing confused the boot process. – Daniel Oct 12 '14 at 17:57
  • Yeah if BIOS settings are correct then USB drive is not - but then it should NOT work on other comp. Keep in mind that Ubuntu does not affect booting up (that early in boot, it is). – Esamo Oct 12 '14 at 18:08

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.