5

I'm trying to move down a chunk of unallocated data all through the end of a hdd containing an extended partition. I'm doing these operations on a live usb, the screenshot below is taken on the main system, that's why partitions are mounted

Here is the state where I'm at: enter image description here

The unallocated chunk should go down to the sdb3 partition.

First steps were ok (delete initial partition, move the chunk of data from the beginning sectors to after sdb2), but I can't manage to resize the sdb4 partition (so as the chunk continues its journey).

I thought GParted wont resize extended partitions was my answer, but unfortunately the live cd does not use the swap partition - and no partitions are mounted. GParted fails with

GParted 0.12.1 --enable-libparted-dmraid

Libparted 2.3

Move /dev/sdb4 to the left and grow it from 20.00 GiB to 79.96 GiB  00:00:00    ( ERROR )

calibrate /dev/sdb4  00:00:00    ( SUCCESS )

path: /dev/sdb4
start: 398,381,054
end: 440,322,047
size: 41,940,994 (20.00 GiB)
move partition to the left and grow it from 20.00 GiB to 79.96 GiB  00:00:00    ( ERROR )

old start: 398,381,054
old end: 440,322,047
old size: 41,940,994 (20.00 GiB)
requested start: 272,631,808
requested end: 440,319,999
requested size: 167,688,192 (79.96 GiB)
libparted messages    ( INFO )

Unable to satisfy all constraints on the partition.
========================================
  • It looks like you're resizing the extended partition to fill the space, can't you just move it? – Nattgew Oct 14 '14 at 19:54
  • thanks for your comment it did help me re-think the issue, see my answer :) – r---------k Oct 14 '14 at 22:53
3

Managed to solve my issue, reflecting on Nattgew's comment.

Since you cannot move an extended partition through gparted, you have to expand it, then move the inside partitions and then shrink it on the other side.

The problem was that the partition was set to be aligned to MiB, and after taking the available space it became unaligned on the right, leaving a small chunk of data on the other side. That was the "unsatisfied constraint", removing the align to MiB constraint solved this since it didn't leave the chunk and could be expanded properly

1

I had the same problem me to. I solved it by doing a right click on the swap partition, and clicking on "swapoff". This operation made the partition free to be moved/resized. Once the modifications that you want to do are done, you can swapon the swap partition again. I am not sure about the final result (if your Linux system will boot correctly in after these operation) so you must make a backup of your system before all this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.