2

I have been trying to solve this problem for many years. I just did a clean install of Ubuntu 14.04 hoping that the problem would be fixed. Unfortunately most of the information on the Ubuntu Community Wiki warns that it is outdated so I am turning to askubuntu for guidance.

I have ans Asus K52F laptop and the in-built speaker don't work. I have tried many fixes for this problem but none of them have worked. Most of them suggest changing a line in /etc/modprobe.d/alsa-base.conf.

alias snd-card-0 snd-hda-intel 
options snd-hda-intel model=dell-m4-1 enable_msi=1 # this line in Ubuntu 14.04

to something like:

options snd-hda-intel model=generic # or
options snd-hda-intel model=asus

I have tried a number of models but none of them have worked. Additonally, many of the solutions suggest making sure the alsamixer are working. I notice that my interface for alsamixer seems to have less options than others, for example, there is no speaker, front or left, or headphone controller. Here is a screenshot of what I see in alsamixer: enter image description here

As you can see the card is HDA Intel MID and the chip is Intel IbexPeak HDMI.

Should there be any other outputs that could be valuable to troubleshoot this problem, let me know in the comments and I will update the question.

  • in alsamixer, press F6 function key : do you have another sound card ? if yes select it with arrow keys and change faders settings, mute state etc ... – laugeo Oct 12 '14 at 19:33
  • @laugeo I have two options when I press F6... default and HDA Intel MID, which I assume are the same and give the same output in the interface. – nicholaschris Oct 12 '14 at 20:05
  • do you have a file "/etc/pulse/default.pa"? if not, see here askubuntu.com/a/225499/167115. – mchid Oct 12 '14 at 21:32
  • Yes I do have that file. – nicholaschris Oct 12 '14 at 23:03
  • Remove the modification in /etc/modprobe.d/alsa-base.conf (soundcard will go to "auto" mode ) , and see if alsamixer shows more fader after shutdown (better than reboot): you are missing "headphone" and "speaker" channel. Do you have windows dual boot ? if yes , do a real shutdown from windows. – laugeo Oct 13 '14 at 7:35
0

First, return everything to default in the config files.

Then, you can install the ALSA oem-audio-hda-daily-dkms package using the following commands:

sudo add-apt-repository ppa:ubuntu-audio-dev/alsa-daily

press Enter and then execute:

sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install --reinstall dkms linux-image-generic linux-headers-generic linux-tools-generic linux-source alsa-firmware-loaders alsa-base alsa-utils alsa-source alsa-tools python-alsaaudio python-pyalsa

reboot, and then run:

sudo apt-get install oem-audio-hda-daily-*
sudo rm /etc/apt/sources.list.d/ubuntu-audio-dev-alsa*
sudo apt-get clean
sudo apt-get autoclean

Reboot and if the drivers aren't loaded, run:

sudo alsa force-reload

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.