3

I'm having a bit of trouble mounting an ZFS pool I've migrated from a FreeNas system to Ubuntu 14.04.

So far I've managed to import the ZFS pool via the zpool import Storage command. I can list all the mount points with the zfs list command. My issue is I don't know how to mount these. Preferably permanently (or on startup).

Any help would be greatly appreciated.

zfs list:

sudo zfs list                                                                                                                                                                                                                                                      ⏎
NAME                       USED  AVAIL  REFER  MOUNTPOINT
Storage                    2.10T 3.09T  1.71G  /media/Storage
Storage/Others             12.9G 3.09T   232K  /media/Storage/Others
Storage/backup_osx         256K  3.09T   256K  /media/Storage/backup_osx
Storage/MyStuff            662G  3.09T   662G  /media/Storage/MyStuff

Update So, I managed to sort it out myself. My problem was, that after I had run the zpool import Storage command, my disks wouldn't show up anywhere (nor should they!!!). After you import the ZFS Pool, you need to mount the drives. If you've installed ZFS on Linux then you can run the mountall command and the mountpoints will be mounted in your system.

A bit of trivia

If you take a look at the zfs list i posted, the NAME corresponds to (in my case) the user's drive on the ZFS Raid array. The MOUNTPOINT corresponds to the place where you want your ZFS drive to show up. So if you run zfs set mountpoint=/media/Storage/Others Storage/Others it will mount the Storage/Others "drive" in your /media/ folder. Note that you will need to mount the parent drive in order for anything to show up. I.e. I would need to mount Storage before being able to mount Storage/Others.

I hope this makes sense, if not, let me know and I will calrify. Also, someone with a bit more knowledge about this subject might find what I've written to be misleading, if so, let me know. This is just the way I understood it.

Also, this thread helped me

  • Please edit your question and add the output of zpool status. – LiveWireBT Oct 12 '14 at 15:48
1

Just to clarify, zpool import alone doesn't import pools, you need to provide the name of the pool or import all pools with the -a parameter. If you do that, all datasets should be mounted automatically. You probably need create folders below the mountpoint that don't exist.

  • 1
    Thanks for you response LiveWireBT, my question was poorly worded. What I meant was, that I successfully imported my pool, but now had to mount it. I figured out how to do it all, and will add it to my question. Sorry for wasting your time :/ – Chris Oct 13 '14 at 7:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.