1

I have dell inspiron 15r turbo 7520 with windows 8 pre installed. I have dual booted the system with Ubuntu 14.04 and I am new to ubuntu. Wi-Fi is showing to be connected but I am not able to access network. When I enter the command (lspci -nn | grep 0280)on terminal it shows Intel Corporation Centrino Wireless -N 2230 [8086:0887] (rev c4) For iwconfig it shows eth0 no wireless extensions. lo no wireless extensions. wlan0 IEEE 802.11bgn ESSID:"UG_4thyr" Mode:Managed Frequency:2.412 GHz Access Point: E8:BA:70:61:0A:E7 Bit Rate=13 Mb/s Tx-Power=16 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=61/70 Signal level=-49 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:23 Missed beacon:0

  • Can you type iwconfig in terminal and paste what it returns here? – jessenorton Oct 12 '14 at 8:22
  • Try the troubleshooting steps listed here: help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide – Brian Z Oct 12 '14 at 9:33
  • @jessenortoneth0 no wireless extensions. lo no wireless extensions. wlan0 IEEE 802.11bgn ESSID:"UG_4thyr" Mode:Managed Frequency:2.412 GHz Access Point: E8:BA:70:61:0A:E7 Bit Rate=13 Mb/s Tx-Power=16 dBm Retry long limit:7 RTS thr:off Fragment thr:off Power Management:on Link Quality=61/70 Signal level=-49 dBm Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:23 Missed beacon:0 – sunnyd Oct 12 '14 at 12:49
  • Small suggestion - edit your question to include the output from iwconfig so other users can see. So wifi is showing to be connected, right? Have you tried going to google.com ? If you can get to google but no other website, your problem may be similar to what i encountered before On my Fedora , i could connect to google but no other website. What i did is go to firefox's about:config page, and search for ipv. Check if network.dns.disableipv6 is set to false – Sergiy Kolodyazhnyy Oct 12 '14 at 20:29
  • @Xieerqi I will update the question as per your suggestion and no I am not able to reach for google.com – sunnyd Oct 14 '14 at 8:32
-1

As you mentioned that you are using ubuntu 14.04 so do the following steps to correct the problem:

  1. Open Software & Updates and go to Additional Divers
  2. Install the fitting driver from there.
  3. Restart your system
  4. Now your WiFi will definitely work and it will show the WiFi signals (within its range) also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.