0

Whenever I try to start my computer it shows the following error:

file /boot/grub/i386-pc/normal.mod not found 
Entering rescue mode... 
grub rescue> 

I tried installing Ubuntu 14.04 onto my computer which was preloaded with windows 8.1. My goal was to make this a dual boot.

I primarily followed these instructions

I accidentally skipped step 5, which was turning off secure boot, and is most likely what led to my current error. Ubuntu installed on my computer but I was unable to run it past the live session which prompted me to try out Ubuntu and/or install it again. But now I can't even get there.

In frustration, I removed my flash drive and that is when I arrived at this screen, which I can't seem to get out of.

If helpful, entering the command ls on the grub rescue mode prompt outputs:

 (hd0) (hd0,gpt 12) (hd0,gpt 11) (hd0,gpt 10) (hd0,gpt 9) (hd0,gpt 8)... (hd0,gpt 2)
 (hd0,gpt 1) 

set outputs:

cmdpath=(hd0) prefix=(hd0,gpt10)/boot/grub root=hd0,gpt10 

These are the only two commands that work (that I know of). I've tried things like, quit, exit, lsmod, but none have worked.

1

So I just now was able to successfully make my laptop a dual boot.

The way I got rid of the grub rescue prompt was actually by changing my boot mode from Legacy Mode to UEFI. I did this by booting into the bios menu when I turned on my computer by pressing f2 (for me). I then scrolled over to Boot and switched this under the Boot Mode option.

This got rid of the grub rescue screen upon powering up my machine. When I turned it on, it took me straight into Windows with no option to choose Ubuntu. My next step was to disable secure boot (see http://technet.microsoft.com/en-us/library/dn481258.aspx for more info on this).

NOTE: the disable secure boot option does not appear until after you switch to UEFI. I was now able to turn Secure Boot Off. The way to do this was also on the BIOS menu. I simply scrolled left to the Security tab (NOTICE: you should see an option for Secure Boot on the Bottom. You need not disable this, since my next instruction will disable it). I scrolled all the way down to Reset to Setup Mode and pressed enter. This Clears PK, disables Secure Boot (see for yourself on that screen) and enters Setup Mode. On a side note: I tried simply disabling Secure boot many times, saving it each time but this did not change anything when I restarted my computer (still booted to Windows automatically).

After this, when I rebooted I had the option to choose Ubuntu or Windows (since Ubuntu was already installed).

I did this on a Lenovo P400. My understanding is that this whole UEFI thing is unique to new operating systems, including but not limited to Windows (8 and 8.1)

  • Don't forget to click the grey at the left of this text, which means "yes, this answer is valid"! ;-) (And please don't put "solved" in the title... :-) – Fabby Jun 1 '15 at 20:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.