5

I'm hoping you guys can help. I've been searching for along time with reading the information on noip.com and couldn't figure out anything.

I've set up an SSH server on a home computer. I changed the port # in sshd_config and forwarded my port number to the router. I can connect to my sever fine if I am on the same network as the server (using ssh -p port# me@private.ip) and can connect fine from a different net work using (ssh -p12xx me@public.ip).

I have setup an noip account and have attained a host-id "me.ddns.net". downloaded the noip-DUC updater to update my ip address. My question, when i tried to ssh -p port# me.ddsn.net (my host name on noip doesn't use the @ symbol), I got a error Permission Denied (public key). To be clear, I can still connect to my server fine using the private ip and the public ip, just not via the host name from noip. As I've mentioned, I do use ssh-keys and have disabled password prompt. Do I need to configure an ssh-key for noip or upload my ssh-keys to noip? I've only been messing with SSH for 24 hours and is very unexperienced. I appreciate everyone's advice.

Thank you.

  • 2
    No, you don't upload anything to noip.com; it's only a name server that allows you to connect to your computer without knowing the ip address. But I think you may need to configure separate keys for connecting via the domain name, the same way you did it for using the IP address. – Marty Fried Oct 12 '14 at 1:41
  • "my host name on noip doesn't use the @ symbol" What do you mean by this? It seems very weird that you need to specify the username when using one address and not when using another. – fkraiem Oct 12 '14 at 1:51
  • Sorry. it's hard for me to explain it clearly. I can connect find via private ip or public ip. I went to noip.com to register for a hostname(or dyndns) since my ups assigned me a dynamic ip which would constantly change. My hosted is me.ddns.net. I saw instruction while researching to connect by ssh@mydomain but that's not the same format my domain is. I just wanted to clarify that. – bbnguyen Oct 12 '14 at 1:56
  • @user308203 please verify what i wrote on on the answer – Manco1911 Oct 12 '14 at 2:17
  • Sorry. I left the house for a moment and couldn't reply right away. I can connect if I'm on the same network using ssh-p 12xx user@server.ip but not via ssh-p 12xx user@noip.address. I've temporarily removed my keys and re-enabled password prompt – bbnguyen Oct 12 '14 at 2:36
2

First of all, You NEVER upload your private keys to anywhere.

Let's get this right.

  • Server is running ssh_d service on a different port (12xx)
  • You forwarded 12xx port on your router to the server.
  • You can connect if you are on the same network using ssh -p 12xx user@server.ip
  • You can connect if you are on another network using ssh -p 12xx user@noip.address
  • Both connections you are using the same origin box (i assume laptop)

Please verify this so we can help you troubleshoot your issue.

Just to give you a heads up since you claimed this is your first time playing with ssh. You need to use the "@" to connect if you are running locally with a different username than the one you want to use on the server. This is:

usernameA [laptop] ---> ssh ---> usernameA [server]

In that case, you would use:

ssh -p 12xx youraddres.no-ip

If you use different usernames, then you have to specify it by using "@". So if this is the case:

usernameA [laptop] ---> ssh ---> usernameB [server]

You should use:

ssh -p 12xx usernameB@youraddres.no-ip
  • 1
    Thank you for clarifying the username@address.no-ip. – bbnguyen Oct 12 '14 at 3:05
  • You are more than welcome. Did this solved your issue? – Manco1911 Oct 12 '14 at 3:06
  • Yes it did. Thank you very much for leading me toward the solution (which I commented above). – bbnguyen Oct 12 '14 at 3:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.