2

I have the problem someone pointed in the forum. But I see everyone have this problem with VM machines. In my case is with bare metal:

When I start the machine I see cloud-init-nonet waiting for network.

--------------------------------
cloud-init-nonet[164.54]: gave up waiting for a network device.
Cloud-init v. 0.7.5 running 'init' at Sat, 11 Oct 2014 22:23:38 +0000. Up 164.77     seconds.
ci-info: +++++++++++++++++++++++Net device info+++++++++++++++++++++++
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: | Device |  Up  |  Address  |    Mask   |     Hw-Address    |
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: |   lo   | True | 127.0.0.1 | 255.0.0.0 |         .         |
ci-info: |  eth1  | True |     .     |     .     | 68:XX:ca:YY:09:50 |
ci-info: |  eth0  | True |     .     |     .     | 00:XX:8c:YY:c7:00 |
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!Route info failed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
2014-10-12 00:25:44,469 - DataSourceMAAS.py[CRITICAL]: Giving up on md from ['http://172.16.0.40/MAAS/metadata//2012-03-01/meta-data/instance-id'] after 126 seconds
2014-10-12 00:25:44,469 - util.py[WARNING]: No instance datasource found! Likely bad things to come!
--------------------------------

Is almost the same thing as seen here:

https://ask.openstack.org/en/question/28297/cloud-init-nonet-waiting-and-fails/

I also tried to explain in this bug:

https://bugs.launchpad.net/cloud-init/+bug/1345433

As I told in the bug it seems to me that openvswitch is not started in order. But I don't know. Maybe it's just my network config that's relaying on openvswitch db.

My config is rather simple /etc/network/interfaces:

### This does nothing, but left here for future reference. It should work. It's supposed to be openvswitch support on startup
allow-ovs br-ext
iface br-ext inet manual
        ovs_type OVSBridge
        ovs_ports eth0


# The primary network interface
auto eth0
iface eth0 inet manual
        up ifconfig $IFACE 0.0.0.0 up
        up ip link set $IFACE promisc on
        down ip link set $IFACE promisc off
        down ifconfig $IFACE down

auto eth1
iface eth1 inet manual 
        up ifconfig $IFACE 0.0.0.0 up
        down ifconfig $IFACE down


#This also does nothing as br-int is not created when this script is executed
auto br-int
iface br-int inet dhcp

Any help on how to solve this? This really messes my startup so much that I'm thinking about removing MAAS and reinstall without the cloud-init stuff.

0

This works for me:

  1. login with :gui by login/pass: vagrant/vagrant
  2. modify the /etc/rc.local file to include the line sh /etc/init.d/networking restart just before exit 0
  3. disable :gui
  4. vagrant up or vagrant reload

https://github.com/mitchellh/vagrant/issues/391#issuecomment-2078383

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.