2

I bought a new acer aspire E5-521 and installed ubuntu 14.04, but the touchpad doesn't work from the beginning. I already tried xserver-xorg-input-synaptics. It says a newer version is already installed. Then I tried what it says in the Debugging and it doesn't recognise the touchpad at all. Unfortunately I have no USB-Mouse to try if it`s working... What can I do? Thank you for your help!

0
1

Latest kernels should fix that, as mentionned on Launchpad.

Reported working on 3.17-rc6

You can find 3.17 kernel in DEB package on http://kernel.ubuntu.com/~kernel-ppa/mainline/v3.17-utopic/

Piece of warning: you might encounter some issues with kernels not released by Canonical (ubuntu), but it should anyhow "work".

0

Try a new kernel as mentioned.

It works for my Aspire E5-571.

See https://askubuntu.com/a/557370/355307

-1

I had a long fight to get the touchpad working (in basic mode, no 2-finger scrolling), finally working:

i8042.nopnp is needed for the problematic ACER Aspire E15 E5-573-C1SG touchpad (no Advanced/Basic mode for touchpad in "F2" BIOS)

/boot/vmlinuz-4.6.1 root=/dev/sda3 ro init=/sbin/e4rat-preload i8042.nopnp i8042.kbdreset psmouse.proto=imps ATHDELAY=1 

ABOVE is for touchpad, below was "delayed modprobe ath10k_pci" (workaround) solution for WIFI ath10k_pci reproducibly crashing kernel on same Acer Aspire notebook:

If not blacklisted (or compiled in kernel), ath10k_pci crashes kernel...

Also crashes if started after x or if started too early (when would be safest ???) sleep 4 usually works:

To adjust sleep time (seconds), parse /proc/cmdline for ATHDELAY=1 or =88888 to postpone :

$ cat /etc/rc.local  # reminder: chmod +x /etc/rc.local
ATHD=`cat /proc/cmdline|awk '{for(i=1;i<=NF;i++){if($i ~ /^ATHDELAY=/){sub(/^ATHDELAY=/,""); print $i}}}' ` ; SLP=$(($ATHD+3)); (sleep $SLP; modprobe ath10k_pci ) &

This worked under Debian Jessie and custom compiled Linux 4.6.1 x86_64 kernel, but (HW + kernel specific, so) might apply to other distros/setups. Marcell Gal, Hungary


MUST be module BUT blacklisted under linux 4.6.1 otherwise KERNEL CRASH at boot.

modprobe ath10k_pci works a few seconds after boot, and no crash, wifi works perfectly !

$ cat /etc/modprobe.d/ath10k-blacklist.conf
blacklist ath10k_core
blacklist ath10k
blacklist ath10k_pci
1
  • 1
    Please fix your formatting, as it is, your answer is very hard to read and it's nearly impossible to identify what parts are your own words and what parts belong to the configuration file or commands. Also, do not use the title formatting unless it's really a headline. Thanks. – Byte Commander Jun 12 '16 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.