0

In a game I'm running through wine (MTM2) due to programmer oversight the physics engine run differently at different frame rates. The physics engine runs "properly" at around 30 FPS. On my machine, the game runs at around 50 FPS.

The fan site recommends using dxtory to limit the frame rate. This program runs at a fairly low level which the wine implementation of directx in wine doesn't support.

Is there any way to get the game to run properly?

0

I don't think there is a way to modify Wine to restrict the framerate, and the problem you're having is clearly a bug in the program, not Wine. Unless the game has a setting to restrict the framerate, you're screwed, but I know one thing you could try. Use Microsoft's implementation of DirectX! Go to http://www.microsoft.com/en-us/download/details.aspx?id=35 and run the installer. I'm assuming you're using PlayOnLinux, so you need to follow some short instructions to make sure itruns in the prefix. Open PlayOnLinux, click on the program in PlayOnLinux's menu, and click on Configure at the top of the window. Choose Miscellaneous and choose the option to run an .exe in the drive. Choose the DirectX installation program, and install. Then you can try that dxtory program you wanted to use.

  • I have tried using winetricks directx as well as microsoft directx 4 which came with the game. I'll try installing the version you linked to though. – Giantblargg Oct 10 '14 at 18:16
  • Installing didn't work. After some research the problem I found that this version of directx doesn't work on wine. ubuntuforums.org/archive/index.php/t-2124135.html – Giantblargg Oct 11 '14 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.