I found a lot of problems similar to mine on the web, but still no real solution. I'm having the annoying

Cannot mix incompatible Qt library (version 0x40806) with this library (version 0x40802)

message whenever I try to launch genymotion. It seems that the problem is either in environment variables or different libraries installed. So, I'm trying to see the output of various commands

  1. echo $LD_LIBRARY_PATH returns nothing (actually there is no environment variable with this name.

  2. dpkg -al | grep libqt (*) returns this list

(*) not sure that is the right command btw

  1. Also tried this command echo LD_LIBRARY_PATH=. ldd ./genymotion and this is the output

4.

qmake --version
QMake version 3.0
Using Qt version 5.2.1 in /usr/lib/x86_64-linux-gnu

Any idea?

up vote 34 down vote accepted

Solved the problem using this solution:

I have fixed this issue doing the following:

  1. Installing the libs:

    apt-get install libxi-dev libxmu-dev
    
  2. (Re-)moving the Qt libs inside the Genymotion installation directory:

    mkdir QtLibs && mv *Qt*.so* QtLibs
    

This last command will make Genymotion use the system's Qt libs.

  • i have the same issue with genymotion on ubuntu, and for me when using this command, genymotion cannot execute anymore – cV2 Feb 18 '15 at 13:44
  • what do you mean by "genymotion cannot execute anymore"? – tigerjack89 Feb 18 '15 at 17:41
  • basically works but I also add to install qtwebkit and qtsvg version 4 – kriss Nov 28 '15 at 10:48

After you have run the following command:mkdir QtLibs && mv *Qt*.so* QtLibs

you will need to install system libs. For me it was:

    libqtwebkit4
    libqt4-svg

You can find out what your system needs by running genymotion from within the command line terminal

This command helped me to start qtcreator without that error:

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$HOME/tools/qtcreator-3.6.1/lib/Qt/lib

where qtcreator-3.6.1 is the installation directory.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.