9

On Installing Virtual box on Ubuntu 14.04, I got following message:

Kernel driver not installed (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a >permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. If it is available in your distribution, you should install the DKMS package >first. This package keeps track of Linux kernel changes and recompiles the vboxdrv >kernel module if necessary.

Then on following the link I entered these commands:

sudo apt-get install linux-headers-generic build-essential dkms
sudo apt-get remove --purge virtualbox-dkms
sudo apt-get install virtualbox-dkms

On Running the last command

sudo apt-get install virtualbox-dkms

I get an error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable 
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
virtualbox-dkms : Depends: virtualbox (>= 4.3.10-dfsg-1)
E: Unable to correct problems, you have held broken packages.

Just for reference, I checked the version of the Virtual Box, I got 4.3.16 r95972

It worked using the solution

sudo apt-get install build-essential module-assistant
sudo m-a prepare

Second as mentioned in the error reinstall kernal module.

sudo /etc/init.d/vboxdrv setup

More Details are from link

11

You need to compile some kernel drivers:

First

$ sudo apt-get install build-essential module-assistant 
$ sudo m-a prepare

Second, as mentioned in the error, reinstall the kernel module.

sudo /etc/init.d/vboxdrv setup

This should solve your problem.

Sometime only second step can solve your problem (so try it first).

Source: http://www.binarytides.com/fix-vbox-kernel-driver-error/

  • Thanks. Ubuntu 14.04. VB stopped working as described from one day to next after a system update. the second step is all I needed to run. – smertrios Jul 16 '16 at 17:01
  • I've tried doing these suggestions, @hunch, and it keeps failing and saying to run dmesg to find out why. I can't interpret that much code. Where do I go to find my error aside from AU (or is AU the best option)? – James Aug 29 '16 at 15:30

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.