0

I'm using Kubuntu 14.04 and I'm asked for password when:

  • Using sudo in terminal.
  • Login.
  • Installing/removing/updating programs with Muon.
  • KWallet initiates or adds a password.

I don't want to write any password. Never tell me the risks.

It still ask me for password when installing programs with Muon.

  • @KasiyA where is Muon in that question? – Arturo Oct 10 '14 at 14:24
  • For that see this askubuntu.com/questions/160364/… – αғsнιη Oct 10 '14 at 16:02
  • That's for updating, I don't wan't to write the password when installing/removing programs. – Arturo Oct 10 '14 at 19:21
5

To disable requiring password for logon, there are a number of solutions listed in this thread here:
Kubuntu Forums - Passwordless login

To disable password for administrative tasks, run sudo visudo and ensure that the line for your user looks like this (replace 'mgodby' with your own user name):

mgodby ALL=NOPASSWD: ALL

Reference for using root sudo:
Ubuntu Community Help - RootSudo

|improve this answer|||||
2

Open "applications" - "system tools" - "admin" - "user accounts". Unlock your account. Click the password button. In the drop down menu of options, select "login without a password".

sudo -i will give you a persistent root login for that session.

To enable the root account type sudo passwd root and set the password. Take a look here:

RootSudo

I have never used muon so will leave that to someone else to answer.

As requested, I will not tell you the risks involved !

|improve this answer|||||
0
  • Sudo: write in terminal sudo visudo, go to the end of the file, press o, then type yourUsername ALL=(ALL) NOPASSWD: ALL. Press Esc, then type :wq!.

  • Automatic login: Alt + f2 -> User Manager -> Check Automatic Login

  • Automatic software updates without typing password: type sudo -s, nano /etc/crontab, go to the end of the file and type 30 14 * * * root apt-get update (updates will perform every single day at 14:30). Then you press Ctrl + x, y, Enter. After that you can do the following to remove notifications and don't worry about updates: Alt + f2 -> Update Manager -> More -> Configure Muon Update Manager.. -> Uncheck "Show notifications for available updates".

  • Disable KDE Wallet password request: Alt + f2 -> KWalletManager -> Settings -> Configure wallet... -> uncheck "Enable the KDE Wallet subsystem". The internet password and so will still be remembered.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.