1

This morning Software Updater showed notification of new updates. The kernel was part of the update which then required a reboot. Once I rebooted, my sound was gone and no longer recognized buy the system. I have tried all I know to do: restart ALSA (forcibly), unload alsa and pulseaudio and re-install both, none of these has worked.

I need the sound back on this machine ASAP and like an idiot, I have already purged previous kernels from the system before I completely checked everything.

Here is the results of uname -a:

Linux z600-ubuntu-64-bit 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

UPDATE:

Ok, sound IS working, just not pulseaudio and the sound notifier (speaker icon). I also noticed that most of my system settings are missing in the control panel. What I have in the control panels is:

Language Support, Security & Privacy, Printers, Landscape Service, and Software and Updates.

That's it. Any ideas?

CONFIGS:

$ cat /etc/pulse/daemon.conf

# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
## more information. Default values are commented out.  Use either ; or # for
## commenting.

; daemonize = no
; fail = yes
; allow-module-loading = yes
; allow-exit = yes
; use-pid-file = yes
; system-instance = no
; local-server-type = user
; enable-shm = yes
; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
; lock-memory = no
; cpu-limit = no

; high-priority = yes
; nice-level = -11

; realtime-scheduling = yes
; realtime-priority = 5

; exit-idle-time = 20
; scache-idle-time = 20

; dl-search-path = (depends on architecture)

; load-default-script-file = yes
; default-script-file = /etc/pulse/default.pa

; log-target = auto
; log-level = notice
; log-meta = no
; log-time = no
; log-backtrace = 0

resample-method = speex-float-1
; enable-remixing = yes
; enable-lfe-remixing = no

flat-volumes = no

; rlimit-fsize = -1
; rlimit-data = -1
; rlimit-stack = -1
; rlimit-core = -1
; rlimit-as = -1
; rlimit-rss = -1
; rlimit-nproc = -1
; rlimit-nofile = 256
; rlimit-memlock = -1
; rlimit-locks = -1
; rlimit-sigpending = -1
; rlimit-msgqueue = -1
; rlimit-nice = 31
; rlimit-rtprio = 9
; rlimit-rttime = 1000000

; default-sample-format = s16le
; default-sample-rate = 44100
; alternate-sample-rate = 48000
; default-sample-channels = 2
; default-channel-map = front-left,front-right

default-fragments = 8
default-fragment-size-msec = 10

; enable-deferred-volume = yes
deferred-volume-safety-margin-usec = 1
; deferred-volume-extra-delay-usec = 0

There is no ~/.pulse/default.pa

Also, I have an Aferglow Wireless Headset. After the MOST recent update, my headset works, but the microphone is no longer recognized or working. It works in Windows/MAC OSX though.

3
  • Ok, seem to be making SOME progress. When I reboot, I hear a tone when the login screen comes up, but once I login - no sound and pulseaudio is not running. When I try to run pulseaudio, I get this error: E: [pulseaudio] module.c: Module "module-udev-detect" should be loaded once at most. Refusing to load. E: [pulseaudio] main.c: Module load failed. E: [pulseaudio] main.c: Failed to initialize daemon.
    – Ken George
    Commented Oct 9, 2014 at 16:08
  • The best way to add additional information to your question is by editing it, with the edit button. It is better visible that way, and comments are mainly for secondary, temporary purposes. Comments are removed under a variety of circumstances. Anything important to your question should be in the question itself.
    – Parto
    Commented Oct 10, 2014 at 5:42
  • Please include the version of your Pulseaudio installation and the content of /etc/pulse/daemon.conf and ~/.pulse/default.pa. Commented Mar 29, 2015 at 15:38

1 Answer 1

0

Ok, so I found the issue. There were some driver artifacts left behind during the upgrade in the .default stopping pulse audio from working correctly. When I removed them, everything started to work normally.

Not the answer you're looking for? Browse other questions tagged .