3

I have virtualbox 4.3.16 with a 64bit Ubuntu 14.04 LTS guest on a Windows 7 64Bit host. Everything seems to work fine, except the fact that any graphics related stuff is very slow. Here is what I did:

1.I installed the virtualbox guest additions using "sudo apt-get install virtualbox-guest-x11". This seems to have installed virtualbox-guest-x11 in version 4.3.10

2.I then changed the settings of my virtual machine to enable 3D acceleartion.

3.I restarted my VM. Screen resolution was fine now, however things were still very slow.

4.I ran the command "/usr/lib/nux/unity_support_test -p", output was very similar to this (maybe the version numbers do not match)

$ /usr/lib/nux/unity_support_test  -p
libGL error: failed to authenticate magic 6
libGL error: failed to load driver: vboxvideo
OpenGL vendor string:   VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string:  2.1 Mesa 10.1.3

Not software rendered:    no
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no

This told me, that 3D acceleration was still not working properly. I figured, that I should probably use the guest-additions in version 4.3.16 as well (as my Virtualbox).

I tried deinstalling my guest-additions with

sudo apt-get remove virtualbox-guest-utils

and

sudo apt-get remove virtualbox-guest-x11

I downloaded the new guest additions from http://download.virtualbox.org/virtualbox/4.3.16/. And tried to install them using

sudo sh ./VBoxLinuxAdditions.run

The program said, that there is still a version of guest-additions installed. I therefore ran:

sudo sh ./VBoxLinuxAdditions.run uninstall

I then tried installing again. The program still said that there was a version installed, but this time I simply let it install anyway and restarted. The effect is, that the output changed but things are still not working.

$: /usr/lib/nux/unity_support_test -p
libGL error: pci id for fd 4: 80ee:beef, driver (null)
OpenGL Warning: glFlushVertexArrayRangeNV not found in mesa table
OpenGL Warning: glVertexArrayRangeNV not found in mesa table
OpenGL Warning: glCombinerInputNV not found in mesa table
OpenGL Warning: glCombinerOutputNV not found in mesa table
OpenGL Warning: glCombinerParameterfNV not found in mesa table
OpenGL Warning: glCombinerParameterfvNV not found in mesa table
OpenGL Warning: glCombinerParameteriNV not found in mesa table
OpenGL Warning: glCombinerParameterivNV not found in mesa table
OpenGL Warning: glFinalCombinerInputNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterfvNV not found in mesa table
OpenGL Warning: glGetCombinerOutputParameterivNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterfvNV not found in mesa table
OpenGL Warning: glGetFinalCombinerInputParameterivNV not found in mesa table
OpenGL Warning: glDeleteFencesNV not found in mesa table
OpenGL Warning: glFinishFenceNV not found in mesa table
OpenGL Warning: glGenFencesNV not found in mesa table
OpenGL Warning: glGetFenceivNV not found in mesa table
OpenGL Warning: glIsFenceNV not found in mesa table
OpenGL Warning: glSetFenceNV not found in mesa table
OpenGL Warning: glTestFenceNV not found in mesa table
libGL error: core dri or dri2 extension not found
libGL error: failed to load driver: vboxvideo
OpenGL vendor string:   Humper
OpenGL renderer string: Chromium
OpenGL version string:  1.1 Chromium 1.9

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: no
GL vertex program:        no
GL fragment program:      no
GL vertex buffer object:  no
GL framebuffer object:    no
GL version is 1.4+:       no

Unity 3D supported:       no

What else can I do? If this is a known issue (according to my research Virtualbox recently had problems with 3D acceleration) which setting (Virtualbox version, Ubuntu version) is known to work fine?

closed as off-topic by Seth Apr 2 '15 at 16:38

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

  • This was asked 5 months ago. If you still have problems please indicate how much total ram has the host system and how much is free?. I suspect your system has very little free memory, and then your host is "swapping" a lot. In general, Virtualbox (and any other HVM virtualization) is no good for 3D acceleration on the guests systems; you need paravirtualization (PVM) to have 3D acceleration, as far as i know. – henderb Mar 29 '15 at 17:42
  • Are you still looking for an answer to this question? – Seth Mar 29 '15 at 18:33