2

I have Moto G - Android 4.4.4. I paired up my phone and wanted to transfer the files from phone to laptop(Ubuntu 14.04). But not able to do it.

enter image description here

Though i am able to browse files through Bluetooth and able access pictures and play videos in Laptop.(That are in my phone)

Output for dmesg | grep Blue

 [   15.929503] Bluetooth: Core ver 2.17
[   15.929525] Bluetooth: HCI device and connection manager initialized
[   15.929536] Bluetooth: HCI socket layer initialized
[   15.929538] Bluetooth: L2CAP socket layer initialized
[   15.929543] Bluetooth: SCO socket layer initialized
[   23.451049] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   23.451053] Bluetooth: BNEP filters: protocol multicast
[   23.451067] Bluetooth: BNEP socket layer initialized
[   23.480577] Bluetooth: RFCOMM TTY layer initialized
[   23.480596] Bluetooth: RFCOMM socket layer initialized
[   23.480603] Bluetooth: RFCOMM ver 1.11

Information regarding the file /etc/bluetooth/main.conf

[General]

# List of plugins that should not be loaded on bluetoothd startup
#DisablePlugins = network,input

# Default adaper name
# %h - substituted for hostname
# %d - substituted for adapter id
Name = %h-%d

# Default device class. Only the major and minor device class bits are
# considered.
Class = 0x000100

# How long to stay in discoverable mode before going back to non-discoverable
# The value is in seconds. Default is 180, i.e. 3 minutes.
# 0 = disable timer, i.e. stay discoverable forever
DiscoverableTimeout = 0

# How long to stay in pairable mode before going back to non-discoverable
# The value is in seconds. Default is 0.
# 0 = disable timer, i.e. stay pairable forever
PairableTimeout = 0

# Use some other page timeout than the controller default one
# which is 16384 (10 seconds).
PageTimeout = 8192

# Automatic connection for bonded devices driven by platform/user events.
# If a platform plugin uses this mechanism, automatic connections will be
# enabled during the interval defined below. Initially, this feature
# intends to be used to establish connections to ATT channels.
AutoConnectTimeout = 60

# What value should be assumed for the adapter Powered property when
# SetProperty(Powered, ...) hasn't been called yet. Defaults to true
InitiallyPowered = true

# Remember the previously stored Powered state when initializing adapters
RememberPowered = true

# Use vendor id source (assigner), vendor, product and version information for
# DID profile support. The values are separated by ":" and assigner, VID, PID
# and version.
# Possible vendor id source values: bluetooth, usb (defaults to usb)
#DeviceID = bluetooth:1234:5678:abcd

# Do reverse service discovery for previously unknown devices that connect to
# us. This option is really only needed for qualification since the BITE tester
# doesn't like us doing reverse SDP for some test cases (though there could in
# theory be other useful purposes for this too). Defaults to true.
ReverseServiceDiscovery = true

# Enable name resolving after inquiry. Set it to 'false' if you don't need
# remote devices name and want shorter discovery cycle. Defaults to 'true'.
NameResolving = true

# Enable runtime persistency of debug link keys. Default is false which
# makes debug link keys valid only for the duration of the connection
# that they were created for.
DebugKeys = false

# Enable the GATT functionality. Default is false
EnableGatt = false
3
  • 1
    The error message suggests that the Bluetooth connection is busy. You may have a dead transfer still running, or the device is auto-connecting twice (or more). It may even be auto-syncing (when first connected). Not enough details to tell you more.
    – david6
    Oct 8, 2014 at 7:15
  • How can i check more on this issue. Can you tell me some commands or other methods to explore on this?.. Thanks
    – hunch
    Oct 8, 2014 at 8:12
  • Can you post output from dmesg | grep Blue ? See: askubuntu.com/questions/375537/…
    – david6
    Oct 8, 2014 at 8:56

1 Answer 1

0

It seems that the firewall/security policy preventing the RW permission, first check Ubuntu firewall rules, enable or allow your access not the device, make trust both the device each other for secure connection. also check the settings from mobile handset.

Remember: flash the default firewall rules always not a good idea. If we assume that the hardware is working find then check the security and policy set on both the devices.

1
  • sudo ufw status command shows -- status inactive. I have not installed any other firewall. is there any chance for other default firewall.
    – hunch
    Oct 10, 2014 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.