I installed a TrueType font by running:

$ sudo gnome-font-viewer somefont.ttf

and clicking the "install" button.

I would now like to uninstall that font (as it seems malformed and makes programs crash when used), but I can't find where it has been installed on the filesystem.

If I run the above command again, there is an unclickable "installed" button where the "install" button used to be, but no option to un-install.

In hindsight I should have just put it in ~/.fonts but alas I did not.

I tried using font-manager, which does appear to have a "remove" button, but the font I installed does not appear there. It does appear in Gimp and Inkscape however, which is where it causes problems.


It turns out even though I ran it as root, it just installed it in $HOME/.local/share/fonts/somefont.ttf (but owned by root), not system-wide (as I had expected).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.