Attempting to install the TP-Link Archer T4U Driver. Downloaded files from https://wikidevi.com/wiki/TP-LINK_Archer_T4U

Have installed build-essentials.

$ sudo make clean

cd hal/OUTSRC/ ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
cd hal/OUTSRC/ ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko 
cd hal/led ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd hal ; rm -fr */*/*.mod.c */*/*.mod */*/*.o */*/.*.cmd */*/*.ko
cd hal ; rm -fr */*.mod.c */*.mod */*.o */.*.cmd */*.ko
cd hal ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core/efuse ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd core ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep/linux ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
cd os_dep ; rm -fr *.mod.c *.mod *.o .*.cmd *.ko
rm -fr Module.symvers ; rm -fr Module.markers ; rm -fr modules.order
rm -fr *.mod.c *.mod *.o .*.cmd *.ko *~
rm -fr .tmp_versions

$ sudo make

make ARCH=i386 CROSS_COMPILE= -C /lib/modules/3.13.0-32-generic/build M=/media/yolande/USB20FD/Wireless Driver/Attempt 1/rtl8812AU_8821AU_linux-master  modules
make[1]: Entering directory `/usr/src/linux-headers-3.13.0-32-generic'
make[1]: *** No rule to make target `Driver/Attempt'.  Stop.
make[1]: Leaving directory `/usr/src/linux-headers-3.13.0-32-generic'
make: *** [modules] Error 2

$ sudo make install    
install -p -m 644 8812au.ko  /lib/modules/3.13.0-32-generic/kernel/drivers/net/wireless/
install: cannot stat ‘8812au.ko’: No such file or directory
make: *** [install] Error 1
  • 1
    I am considering buying this device and I was wondering if you were able to make it work. If so why haven't you selected a correct answer? I really want to know about your experience with the usb adapter. – Torrien May 21 '16 at 2:07

I just did the following (on Ubuntu 14.04 LTS) which worked. Make sure you have a working internet connection. Unplug the T4-U. In a terminal:

git clone https://github.com/abperiasamy/rtl8812AU_8821AU_linux.git
cd rtl8812AU_8821AU_linux/
sudo make install

If you the plug in the T4-U (no restart or log out needed), it is recognised.

(Answer based on this article: http://wiki.beyondlogic.org/index.php?title=TPLINK_Archer_T4U_RTL8812au_Linux_Drivers, which is slightly outdated since there's no need to manually add the T4-U ID anymore).

  • It works, although you might want to have a look at the bundled README.md to setup DKMS so that the module gets rebuilt automatically every time your kernel is updated. – Apteryx Nov 17 '15 at 21:59
  • thanks a ton for this, I was in line with customer support for many hours and they could not solve it . Luckily found this link before returning it. – Amarjit Dhillon May 4 '18 at 18:25

'make' has trouble with path names with unescaped spaces in the names. I suggest you rename:

USB20FD/Wireless Driver/Attempt 1/rtl8812AU_8821AU_linux-master



And then try again.

  • I had this problem as well, and renaming spaces out of the parent directories fixed it. – Jim Salter Sep 17 '16 at 19:27

I have TP-Link Archer T4U and found the best solution here WiFi module 8812AU not working with kernel version >= 4.4.0-28-generic

sudo -H gedit /usr/src/rtl8812au-

Then change line 4 from MAKE="'make' all" to MAKE="'make' all KVER=${kernelver}"

Save and exit the editor then do the same with:

sudo -H gedit /var/lib/dkms/rtl8812au/

As a similar problem was reported on Ubuntu Forums and my edits have worked for the last kernel update I got.

For your current kernel you should be able to:

dkms build rtl8812au/ -k 4.4.0-38-generic
dkms install rtl8812au/ -k 4.4.0-38-generic



If you are on the latest (4.8.1) kernel now and experience issues with other drivers, please feel free to try mine: https://github.com/Grief/archer-t4u It can also work on older kernels but I cannot guarantee

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.