0

I try to develop an app with Ubuntu SDK. For that I use a Samsung Galaxy Nexus phone running with Ubuntu Touch 13.10 Saucy.

I created a project in Ubuntu SDK (App with Tabbed UI). My Device Kit is: UbuntuSDK for armhf (GCC ubuntu-sdk-13.10-saucy). There is no newer version of Ubuntu Touch for the Galaxy Nexus phone. Trusty or Utopic is not supported anymore.

Allmost independently what Ubuntu Project I try, the error is this:

ERROR:root:Could not find any typelib for Click
Traceback (most recent call last):
  File "/tmp/qtc_device_applaunch.py", line 25, in <module>
    from gi.repository import Click
ImportError: cannot import name Click

Is this a problem with the version of my phone?

0

You should upgrade your ubuntu-touch image with the one available in the devel channel.

But the error that you get is caused by a missing dependency, try to manually re-install the debian click package on your host, open a terminal and type:

sudo apt-get install --reinstall click python3-click 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.