1

I have a fresh install of Ubuntu 14.04 on an HP Pavilion DM4 1200. I can see all of the local SSID's in my area including my own. However when I provide my WPA Personal key to login into my wireless Apple Router it does not authenticate and times out. I can connect via Ethernet.

I have searched many of the Ubuntu solutions including building and updating the more recent Broadcom STA driver without success. I have updated the installation. I haven't found this specific issue and would appreciate being led in the corrective direction.

lspci -nn -d 14e4:

02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01)
  • Can you connect to other WI-FI networks? and can others connect to your Apple router? – rubo77 Oct 7 '14 at 15:34
  • You've been through all this already? askubuntu.com/questions/55868/… – Brian Z Oct 7 '14 at 15:49
  • Which driver is in use? brcmsmac is preferred. – chili555 Oct 7 '14 at 15:49
3

thanks all solved my problem thanks to: https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

once it purged the Broadcom STA proprietary driver and installed the brcmsmac driver it worked perfectly on reboot

| improve this answer | |
1

An additional stage might be required, for those who find that simply installing the correct driver (out of the three) does not solve the issue.

I had the same problem, but on 16.04. After much searching I discovered that for this wifi card (14e4:4727) to connect (in the UK at least), it needs its country code set.

Symptom: NetworkManager applet can see wifi AP, but when I enter password to connect, it repeatedly comes back with request for the password. This applies even if the wifi AP is unsecured.

Solution: remove any incorrect drivers you might have installed e.g.

$ sudo apt-get purge bcmwl-kernel-source

A fuller explanation of this stage is on Installing Broadcom Wireless Drivers )

Install the "linux-firmware" driver that is part of the distro (you can use synaptic).

What is missing from the above excellent tutorial is that you might then need to edit the regional file for the card. The card needs to know what country you are in as broadcasting wifi radio on certain frequencies (e.g. Channel 12 and 13 in USA) is illegal in certain countries.

$ sudo gedit /etc/default/crda

Alter the last line to read:

REGDOMAIN=ETSI country=GB

I'm not too sure that "country=GB" is needed or that it is syntactically correct, but once I saved the file, my wifi connected without issue.

| improve this answer | |
0

Maybe this helps: https://answers.launchpad.net/ubuntu/+source/gnome-nettool/+question/251650

  • forcing the wireless router to use wireless-G (54 Mbps) speeds for troubleshooting purposes
  • changing the access point name from "FRITZ!Box 6320 v2 Cable" to fritzbox without any special characters or spaces in the SSID name.

Then reboot the router and your PC and retest wireless.

  • Also changing to wireless channel 11 in your router will help.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.