5

I have a file that I'm going to be editing and then saving multiple copies of so that I can run them in a model I'm using.

Having edited the file I now don't seem to be able to save it under a different name.

gedit NAMELIST.IN &

(I then edited the text within the file)

I definitely need the original file back. I can't any nice simple GUI button thing at the top of the window(?) for this. Is there a command line way to do this nice and neatly?

Ideally I'd like to save the file as

TMB_RUN_1_NAMELIST.IN

EDIT*** Save as is greyed out. However, the shortcut Crtl+Shift+S is working? And I've found that I can save it by right clicking on the gedit tab.

Any thoughts on why Save As might be greyed out and how I might be able to look at that would be welcome. ***EDIT

closed as unclear what you're asking by Eliah Kagan, Sylvain Pineau, αғsнιη, Eric Carvalho, g_p Oct 8 '14 at 18:10

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Presumably File > Save As... was what you tried first. What happened? How did it not work? Was the problem that the menu bar (with File, Edit, View, and so forth) doesn't appear at the top of your Gedit window? If it doesn't, what happens when you bring your mouse pointer up to the top of the screen? Does the application menu appear in the top panel? And what does "I can't any nice simple GUI button thing at the top of the window(?) for this" mean? When you say you "need the original file back," do you mean you've already saved over the original file and need to perform data recovery? – Eliah Kagan Oct 7 '14 at 13:42
  • "Save As" is greyed out. – Reluctant_Linux_User Oct 7 '14 at 15:36
  • Sounds like a bug – Lambart Oct 7 '14 at 18:02
2

gedit(GUI) provide the Save As option. You can either press Ctrl+shift+S or can go to File=> Save As or Right click on the file name, it gives you the Save As Option.

This may help you. But yes there is no direct button to save as.(In GUI)

  • "Save As" is greyed out. – Reluctant_Linux_User Oct 7 '14 at 15:37
  • Is there some error prompt available when you click on (greyed out) Save As or you are just not able to use this? – hunch Oct 7 '14 at 16:09
  • Hi this issue is resolved. the Crtl+Shift+S method worked. The Save As was still greyed out in the menu. But was available after a restart - just needed to not lose what I'd done/the original file. Thanks for your help. – Reluctant_Linux_User Oct 7 '14 at 16:19
4

Sounds like a gedit bug. Specifically, this one:

https://bugs.launchpad.net/ubuntu/+source/gedit/+bug/1248373

1

The "File" item on gedit's File-Edit-View... menu should have options for: New, Open, Save - and Save As.

  • The keyboard shortcut for this is shift+ctrl+s – Charles Green Oct 7 '14 at 13:26
1

This will do it for you:

  1. Press & Hold Alt
  2. You'll see a menu in the Title Bar of the current(gedit) window
  3. Go to File
  4. Then, Save As
1

This is more suitable for a comment I suppose, since this isnt really an answer but a work-around, but I have this problem as well. Sometimes when I simply double click an icon to open a file in gedit, "Save As" is greyed out and I cant perform this action. However, right clicking the file, and selecting "open with gedit" allows me to "Save As". No idea what the difference is.

Not the answer you're looking for? Browse other questions tagged or ask your own question.