5

I'm new in Ubuntu and I have some small problem with my wifi. I manage to connect it after an hour of using this forum, however now whatever I'm doing I'm loosing the connection every few minutes. I think it started when I've installed dropbox and all of the software required for it. I have to turn off and again on network to get it for next few minutes.

 - Ubuntu version 14.04 
 - asus x550L
 - belkin f7d2301 v1

I have logged to another account and everything was fine before I have installed dropbox.
Any ideas how to fix it? I have such a limited knowledge about this system that I don't even know where to start.

Edit: I have blocked IPv6 and worked without dropbox, problem still occur. I have noticed that it's more likely to appear if I open 2-3 tabs at the same moment, or download update and at the same moment open tab; watch playlist on youtube so it download all the time..

Any ideas how to fix it? I can't believe I have such a problems with linux from the very beginning.

Edit2: should I maybe change my router settings? I have almost default from benkin. Dynamic connection on channel 10, bandwidth 20/40, 802.11e/WMM QoS on; wpa-psk+wpa2+psk.

Edit3: I had enough of it so I have reinstalled system. Same story, installed dropbox which was updating something, using internet and crash after 20sec.

Edit4: I tried to play with MTU, no idea how to change it on my router but I learned that I should have 1472 (+28 = 1500). I added to /etc/dhcp/dhclient.conf two lines:

default interface-mtu 1500;
supercede interface-mtu 1500;

It didn't change anything. It seems like I'm trying to use too much internet (?). I made limit 1024 kb/s on dropbox and it works. However when I try to update information in "incomplete language support" it crushes..

  • Can you append the output of iw reg get to your question? – Charles Green Oct 7 '14 at 17:29
  • country US: (2402 - 2472 @ 40), (3, 27) (5170 - 5250 @ 40), (3, 17) (5250 - 5330 @ 40), (3, 20), DFS (5490 - 5600 @ 40), (3, 20), DFS (5650 - 5710 @ 40), (3, 20), DFS (5735 - 5835 @ 40), (3, 30) (57240 - 63720 @ 2160), (N/A, 40) – Crowell Oct 8 '14 at 13:55
  • The only other thing that helped me significantly was fully disabling ipv6 – Charles Green Oct 8 '14 at 13:57
  • how can I do that and will it influent somehow mu connection? – Crowell Oct 8 '14 at 14:14
  • Will need to post it into an answer - will take a couple of minutes. – Charles Green Oct 8 '14 at 14:15
3

I had an issue with either my ISP or my router - don't really care which it was. Ipv6 was not being handled well, and causing periodic disconnects.

I disabled ipv6 according to instructions I found on itsfoss.com - The following lines are added to /etc/sysctl.conf

net.ipv6.conf.all.disable_ipv6 = 1
net.ipv6.conf.default.disable_ipv6 = 1
net.ipv6.conf.lo.disable_ipv6 = 1

This is best done from a terminal: press alt+ctrl+t to open a terminal window, and enter the command sudo nano /etc/sysctl.conf to start an editor with the file open. Add the lines by typing them, or copying them from here (shift+ctrl+v to paste), and press ctrl+o to write the file, and ctrl+x to exit the editor. You will need to reboot for the changes to take effect.

Because I seem to be a little OCD, I also set IPV6 to IGNORE in the NM applet

| improve this answer | |
  • I tried it, I made ctrl+o and didn't change the name so I saved 66 lines.. I guess it's ok :) I hope now it'll be fine, if so I will write here during next few days. Thank you for you help! – Crowell Oct 8 '14 at 15:19
  • I've been watching video on youtube and I was disconnected. I will try to work on one profile without dropbox do be sure that this is the reason.. – Crowell Oct 8 '14 at 20:10
  • It has no connection with dropbox besides the fact that dropbox generate trafic, if it has many files to download internet crash. – Crowell Oct 9 '14 at 20:38
  • Please run the script that is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…> – Wild Man Oct 13 '14 at 15:04
  • I've added it here askubuntu.com/questions/536468/… – Crowell Oct 14 '14 at 7:46
2

Try running this command in terminal:

iwconfig

If that shows power management: on you need to change it to off by running this command:

iwconfig [wifi-id] power off
| improve this answer | |
  • :~$ ifconfig wlan0 wlan0 Link encap:Ethernet HWaddr 46:6a:b6:be:66:fb UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B) :~$ ifconfig wlan0 power off power: Host name lookup failure ifconfig: `--help' gives usage information. I'm lost. I tried it even when I didn't see this power management line, but still. – Crowell Oct 7 '14 at 14:50
  • 1
    I have found line powrt management: off after typing iwconfig – Crowell Oct 7 '14 at 15:07
  • @Crowell okay. Changed it in my answer. If it's set to off, then I don't know what the problem is. – Dan Johansen Oct 8 '14 at 12:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.