My Shared clipboard has stopped working all of a sudden after a dist-upgrade. I tried re installing guest additions but it doesn't seem to work. I've checked that "Bidirectional clipboard" was enabled.


5 Answers 5


Started working after running: sudo apt-get install virtualbox-guest-dkms and enabling bidirectional shared clipboard.

  • 23
    I also had to reboot.
    – Bruce
    Commented Jun 8, 2015 at 1:58
  • It worked for me by just putting bidirectional instead of host to guest or whatever you have.
    – user454067
    Commented Sep 23, 2015 at 23:51
  • 1
    Its giving - Unable to locate package virtualbox-guest-dkms
    – Yogesh D
    Commented Nov 22, 2016 at 16:50
  • 1
    My guest-system found it that package - but the clipboard functionality is still broken. Also, the guest additions ISO - "cannot mount" issues - having to shut down the guest and remove / add a rom-drive to it in "settings" every time I wanted to mount or unmount it. Clearly linux guests and/or certain window-managers are only barely supported or these things would work out of the box. Windoze guests work fine. UPDATE: Vitor Verreira's solution worked. Just keep on trial-and-error with every fix until one does - too bad none of this is in the instructions.
    – JosephK
    Commented Feb 10, 2017 at 10:04
  • 3
    Did you install that package on the host or guest machine? Commented Jun 12, 2018 at 18:08

Mine wasn't working too, Windows 7 64bit running Ubuntu 10.04. Running the following commands on the guest machine solved for me:

sudo VBoxClient-all stop
sudo VBoxClient-all start
  • 3
    Unfortunately, it appears you must do this each time you reboot your virtual-machine - but much better than not getting it to work at all !! I am running a Debian guest inside a CentOS7 host, and this was the only fix that worked.
    – JosephK
    Commented Feb 28, 2017 at 8:00
  • No effect on Ubuntu 17.10 Budgie guest on Ubuntu 16.04.3 host. Commented Dec 13, 2017 at 6:32
  • 1
    Work with guest Lubuntu 18.04. Host Lubuntu 18.04. Tnx! Commented Nov 4, 2018 at 0:05
  • Even after a savestate and resume of a machine I have to run it to get it working. Pitty but nice workaround! Commented Jan 27, 2019 at 12:28
  1. In VirtualBox Menu Devices -> "Insert Guest Additions CD image…"
  2. Follow all prompts and accept all installs
  3. Reboot

This worked for me with Windows 10 Host and Ubuntu 16.04 Guest.

  • I'm sorry, I can't find "Devices" anywhere in the VirtualBox UI. This problem is going to happen most often to people who have just started using VirtualBox. We don't know our way around the UI.
    – Spike0xff
    Commented Jun 19, 2018 at 19:59
  • 1
    Tried all others, only this one works for me, thanks!
    – cn123h
    Commented Mar 8, 2019 at 20:13
  • I had to do sudo apt install build-essential before trying to install Guest Additions. The version I have required the build tools.
    – Tim
    Commented Oct 8, 2019 at 3:02
  • Worked for guest ubuntu 18 and windows 10 host. Commented Dec 13, 2019 at 13:06
  • Nope. Step #2 there is nothing to follow, after you insert the Guest Additions CD image" nothing happens, you have to go and manually run it. cd /media/cdrom0/ (the path where the BoxGuestAdditions.iso was mounted) sh ./VBoxLinuxAdditions.run Then rebooted the guest, the host, but still no clipboard exchange between OS. Of course I have the share Clipboard - Bidirectional enabled. Of course I have the extension pack installed. It simple does not work easily. . . There's need to be something else, is not that simple as stated above. Commented Feb 22, 2020 at 6:09

I've had same issue.

1) Enabling bidirectional shared clipboard
2) Type following commands:

sudo apt-get update  
sudo apt-get install virtualbox-*  
sudo shutdown -r now
  • This works for the latest Ubuntu distribution (16.10) running VirtualBox on MacOSX. Commented Dec 22, 2016 at 16:16
  • 3
    All other suggestions didn't work but this one worked with Ubuntu 17.10
    – Guerrilla
    Commented Oct 23, 2017 at 23:41
  • 1
    This breaks a clean install of lubuntu
    – risail
    Commented Nov 16, 2017 at 18:45
  • 2
    You don't need to install all the virtualbox-*. I installed virtualbox-guest-dkms, which depends on virtualbox-guest-utils, and it recommended I install virtualbox-guest-x11, so I did so as well. It appears that the guest additions are working
    – Justin
    Commented Nov 20, 2017 at 7:37
  • This broke a fresh Ubuntu 17.10 for me. Had to apt-get remove virtualbox-* to recover.
    – ripper234
    Commented Dec 2, 2017 at 16:13


I run Windows 7 64 bit, Linux inside Virtual Box v4.3.16 r95972. After building a new 3.17 kernel on one of my VM's the guest additions in general stopped working (this included both Cut&Paste and the window resizing).


I found I needed the later version of virtual box guest additions from Oracle, loaded as an .iso file, and another utility called parcellite. My cut and paste is a two step operation.

Attempted fixes:

I tried removing and reinstalling various guest additions (iso, dkms, x11) using the apt-get remove and apt-get install all to no avail. Then I noticed that I had problems reading the virtual CD (VERR_PDM_MEDIA_LOCKED) where I had originally loaded another version of the guest additions from Oracle.

It turned out that the guest additions from Oracle were 4.3.16 (see this via modinfo vboxguest) and the versions from apt-get were 4.3.10. However in order to re-install the later version from the .iso file I had to find a way around the CD mount problem.

What finally worked for me was to make sure that all CD's were unmounted from all of my VM's using the 'Devices -> CD/DVD Devices -> remove disk' selection and then to mount the .iso file via the VirtualBox Manager via the Settings -> Storage -> IDE Controller "CD icon". When I selected the .iso file from the VirtualBox Manger its installation window popped up in my VM, but trying to access this file from the VM always failed.

Once this installation finished I power cycled the VM and the guest additions worked again.

Cut and Paste still seems to have an issue that I had worked around before. The work around is to install parcellite (Ubuntu software center or apt-get). This is a clipboard manager that creates an icon in the top right where you can access the clipboard for cut and paste. Using the left and right mouse buttons to select text in an xterm window cuts to a different buffer than the clipboard (I read online) which is why it does not seem to work between machines.

So to cut and paste to Windows from a Linux xterm I do a multi step process: - first select the text using left and right mouse clicks, - then open parcellite and select History, which opens an Editing Clipboard window.
- Use the mouse middle mouse button to paste into this clipboard.
- Then select the text (again!) using the mouse, after doing the right click here you get a pop-up selection where you select 'Copy'.
- Now when you paste into a Windows area the text you 'Copy' selected appears.

Hope this helps! - Jon Shapiro

  • 1
    I didnt have any issue with resizing .It was only with the copy/paste feature. Thanks for the tip i will definitely try Commented Oct 8, 2014 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .