0

I'm having issues on my installation of Ubuntu 14.04 LTS that have only started happening very recently. Basically, it seems that anytime I perform any add, modify, move, copy, or delete a file on my file system and when opening images in the default image viewer, after a few moments of completing the task, the entire UI freezes except for the mouse cursor, which is restricted to staying on the single screen that it was on when the UI froze (I.E. I can't move the mouse to the other of my dual monitors). The freeze lasts for a short while...maybe 30 seconds to a minute (I'm not quite sure exactly how long it is though), after which the UI continues to function and anything that tried to do with the mouse (other than move it to the second monitor) while the UI was frozen executes as it should in the correct order as well. I've also noticed that my load average is hardly a 2 when the freeze begins, but is around 18 or so after the freeze ends (I have an i7 with 4 hyperthreaded cores). I assume that the load average of 18 is probably because it has tons of queued processes ready to execute that were put off during the freeze. However, when I edit/move/copy/create/delete files in an editor like Sublime Text or Android Studio no freeze occurs whatsoever. The freeze occurs regardless of whether or not I perform the action(s) in the terminal or in nautilus. I've searched and searched and I can't find an answer to why this is happening. Perhaps I don't know the right thing to search for, but I hope that someone here can help.


My setup:

  • Ubuntu Version: 14.04 LTS (latest updates installed)
  • Partition Containing OS: sda5 (Format: ext4)
  • RAM: 12 GB DDR3 (3-Channel)
  • I've verified that swap is indeed working. However, it seems that it is never used. Not sure though.
  • My home directory is actually a symbolic link to the root of another 1 TB HDD found at /mnt/Data (sdb1 - ext4 format)


My HDDs/Partitions (All are MBR partitioned and use SATA connections):

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT   FORMAT
sda      8:0    0 931.5G  0 disk
├─sda1   8:1    0     1K  0 part              Extended
├─sda2   8:2    0 232.9G  0 part              HFS+
├─sda5   8:5    0 221.2G  0 part /            Ext4
└─sda6   8:6    0  11.7G  0 part [SWAP]       Swap
sdb      8:16   0 931.5G  0 disk 
└─sdb1   8:17   0 931.5G  0 part /mnt/Data    Ext4
sdc      8:32   0 931.5G  0 disk 
└─sdc1   8:33   0 931.5G  0 part /mnt/Backup  Ext4
0

It's normal that you would not see much, if any, swap usage unless you are using an app that really needs a lot of RAM, so I wouldn't worry about that.

However, the fact that your home directory is a symbolic link to a different drive might be a problem; is there a reason for that? Normally, you would mount the home directory, not link to it. It would certainly be easier to just mount ~/home to /mnt/home or /mnt/Data/home, wouldn't it? I'm not sure, but there may be some overhead to following the symbolic link every time it needs to access your home directory. You could easily find out by temporarily mounting it and removing the link as a first step in troubleshooting.

Added Info:
Normally, you would mount /home/uname directly, so other users can mount their own home directory elsewhere, if desired. You can mount any directory any place you want, actually, although there are conventions.

However, it sounds like you want to configure your system the same way I always have, which I think is actually superior...

I create the equivalent of your /mnt/data for all my personal data, with directories such as /mnt/data/Documents, /mnt/data/Music, Downloads, Videos, etc. I keep my home directory just like it installs (or reinstalls).

Then I create symbolic links inside my home directory to these subdirectories, but leave all the configuration files, directories, etc as is.

There's an easy way to do this using Nautilus that maintains the special icons for the special directories, although it can be edited. I can give you more details after we (or someone) figures out your main problem, in case it has nothing to do with links. Doing this, I cannot really tell the difference between a normal setup and the links, until I need to reinstall, then I repeat; it doesn't take long.

I don't really think having the symbolic link make a difference for your problem, but my suggestion was to test it just to see. I can't tell you how many problems I've solved by trying things that I didn't think would make a difference, only to find out they did. Then I try to figure out why.

  • I never thought to mount the home directory directly. However, I've had my home directory setup like this for years and only recently I've had these problems. Also, as a small correction, /home/uname -> /mnt/Data is what my home link is. The reason for doing this is because I like to do clean install upgrades, this insures that I don't need to worry about losing any data in that process nor do I need to copy a ton of files either. – bsara Oct 7 '14 at 0:11
  • @bsara: I added some more info the my answer - it was too much for a comment. – Marty Fried Oct 7 '14 at 0:38
  • BTW, I originally did it this way to share media and documents with a windows partition, but I no longer use Windows except in a VM for special cases. – Marty Fried Oct 7 '14 at 0:41
0

I had the same issue (it applied only to my home folder) usage of disk freezes ubuntu for few seconds and I solved it by removing few folders containing a large amounts of files from my home folder. Unfortunately, I don't know any other, more "peaceful" solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.