0

Just upgraded to ubuntu 14.04 from Ubuntu 12.04. After a bunch of problems with my mouse and keyboard not working at the login screen with kernel version 3.15, I went to grub and switched to a lower kernel version (3.5...), and everything was working fine. However, I tried to update to the latest kernel version, which is 3.17, and realized that I can log in, but after that I get a notice that says that there is a problem with my system. If I click report, nothing happens. If I click on cancel (multiple times), it closes the warning panel, and the 14.04 background is visible, but nothing loads; no sidebar, no applications are able to load, and the keyboard shortcuts for the terminal do not work. So, I am left looking at the background.

Does anyone know what is happening or have any experience with this issue?

Thanks,

Chmod

  • How did you get "lower kernel versions" to appear in GRUB? Did you compile or install with apt? Also, why did you have kernel 3.15 at all on Ubuntu 14.04? – John Scott Oct 6 '14 at 15:27
  • 3.17 was released yesterday and although there were 7 RCs chances are that bugs are present... – Jan Oct 6 '14 at 16:07
  • Related (or maybe a duplicate): askubuntu.com/questions/17381/… – Parto Oct 6 '14 at 17:26
  • Yes, I did upgrade with apt. I am not sure why the lower kernel version showed up, but that one is the only one that is working currently. – Chmod Oct 6 '14 at 21:16
  • @Parto, I looked at the askubuntu link. I will attempt to try it out, but I am not sure that it will solve my problem since I can log in; there is a graphical interface until I log in... I am not sure why it switch off after that. It's also showing me that I have system errors, but I can't see them because the panel does not seem to work to display them. – Chmod Oct 6 '14 at 21:21
0

First you should try to obtain the latest drivers for your video card if you are using proprietary drivers. The best way is a manual installation using the installer from the manufacturer's website.

For open source drivers, the PPA below provides near bleeding edge builds which are compatible with the latest mainline kernel usually. It will also have repackaged proprietary installers.

I had a similar issue that was solved by updating mesa and several other libraries through the Xorg-Edgers PPA. This is usually the case in my experience for updating kernels, they need an updated x server and 3d libraries to work with it.

First install ppa-purge sudo apt-get install ppa-purge

Then add the ppa

sudo add-apt-repository ppa:xorg-edgers

This will add the repository to your sources.

sudo apt-get update

Reload the packagelist and finally upgrade

sudo apt-get upgrade

Some packages may be held back, if some are use this

sudo apt-get dist-upgrade

If you have any issues use

sudo ppa-purge -p xorg-edgers

This will completely remove the repository and re download missing packages.

  • I am unable to find ppa:xorg-edgers. I also tried this: launchpad.net/~ubuntu-x-swat/+archive/ubuntu/x-updates But that also doesn't seem to exist, when I try to add it to my repo's list. :/ I think that it may just be a graphics driver problem because I can ssh fine into the machine. But, I am not sure what driver it needs. It might be an nvidia driver issue, however, I am not sure which to download. I have a Dell, btw. Don't know if that makes a difference or not. – Chmod Oct 8 '14 at 19:16
0

FIX: I switched to X, by using Ctrl+Alt+F7. Then, I uninstalled xorg and reinstalled it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.