I recently installed Ubuntu 14.04 in my laptop machine. I use wifi to connect to the network. Everything works fine except that I am not able to access network after 15 minutes or so.

I have to do ifdown wlan0 followed by ifup wlan0 to bring back the internet connection.

I got this solution which suggested to reinstall some modules from here but unfortunately it did not help fix my problem.

sudo rmmod iwldvm #otherwise iwlwifi refuses to stop
sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1
sudo modprobe iwldvm

My /etc/network/interfaces file looks as below.

cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
wpa-ssid My_SSID
wpa-psk My_SSID_Password
dns-search lan
dns-domain lan

Is there something that am missing? It is frustrating to just run ifdown and ifup every 10 minutes. I could have a script to run every 10 minutes to run ping, ifdown and ifup or so but that seems a somewhat ugly solution. I removed my connection details from network manager but the problem still persists.

lspci -d $(lspci -nn | grep 0280 | grep -oP '\[\K[^]]*:[^]]*') -k
09:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
    Subsystem: Intel Corporation Centrino Wireless-N 1030 BGN
    Kernel driver in use: iwlwifi

Output of inxi command is,

CPU~Dual core Intel Core i5-2410M CPU (-HT-MCP-) clocked at Min:800.000Mhz Max:2301.000Mhz Kernel~3.13.0-36-generic x86_64 Up~7:16 Mem~2110.7/3860.2MB HDD~500.1GB(4.0% used) Procs~211 Client~Shell inxi~1.9.17 


I just got disconnected from wifi and when I did dmesg | tail -50, I saw this piece of information which I thought might be useful.

[26306.892459] wlan0: deauthenticated from f8:e4:fb:99:cb:99 (Reason: 6)

I tried the option as suggested in this answer and added an entry options iwlwifi 11n_disable=1 to my /etc/modprobe.d/iwlwifi.conf file to disable the 802.11 protocol. However, I still faced connectivity issue after a while. I see this information while I was disconnected.

cat /var/log/syslog | tail -10
wlan0: SME: Trying to authenticate with f8:e4:fb:99:cb:99 (SSID='my_ssid' freq=2437 MHz)


Since I have configured the network using /etc/network/interfaces, I completely removed the network manager using sudo apt-get purge network-manager. However, this option also did not help me. I am looking for some other solutions.

1 Answer 1


After making the below changes in my /etc/modprobe.d/iwlwifi.conf file and a system restart, I do not see any frequent disconnects.

options iwlwifi 11n_disable=1 wd_disable=1

I believe it might help someone in future.



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .