1

I got compiz to work with Ubuntu trusty. The workspace switcher plugin works very well, however with the desktop cube plugin i get strange distortions while the cube is shown:

[screenshot]

enter image description here

Looks like the 3D / texture logic is failing or something. (Once the desktop switch is finished everything's back to normal).

Has anyone seen this before / any idea how to fix this ?

For reference:

  • graphics card is an intel integrated card, previous ubuntu versions had no problem with it. (Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics card)
  • this is compiz 0.9.11.2 (1:0.9.11.2+14.04.20140714-0ubuntu1)
  • ccsm profile (without default values)
  • Please clarify "previous ubuntu versions had no problem with it" Do you intend to say the earlier versions had no issues with the desktop cube plugin? – Elder Geek Oct 6 '14 at 13:08
  • 1
    Yes, it all works perfectly in lucid, i'll check precise... – lemonsqueeze Oct 6 '14 at 16:01
  • precise works like a charm as well. – lemonsqueeze Oct 7 '14 at 5:35
  • Are all the CCSM settings the same on the tested versions? – Elder Geek Oct 8 '14 at 13:43
  • Is skydome enabled? There is a related bug: bugs.launchpad.net/ubuntu/+source/compiz/+bug/1330080 – Elder Geek Oct 8 '14 at 13:58
1

I had similar problems with an Acer D270. The graphics were laggy and unacceptable. My solution was to switch to a lighter weight distro without 3d effects. Both Lubuntu and Xubuntu will work well with your system.

|improve this answer|||||
  • 1
    I couldn't agree more: this one here is an Acer as well, running xubuntu + mate atm, works very nicely. Plain ubuntu was pretty horrible there. – lemonsqueeze Oct 13 '14 at 21:25
0

After reviewing your ccsm settings I think what you are missing is:

[cubeaddon] s0_deformation=0

Open Compiz Config Settings manager. You will be warned to use caution. Click OK.

Enter deform in the filter box then click the button shown below:

ccsm1

Set Deformation to none. My settings are shown below. I'm not positive the other Cube Reflection and Deformation settings relate to your specific issue however if simply changing deformation to none doesn't do the trick you can try them.

ccsm2

|improve this answer|||||
  • I just tried but the distortion is still there. I'm thinking this really looks like a rendering issue, it might be more of an OpenGL issue than a compiz one ... – lemonsqueeze Oct 10 '14 at 14:59
  • Could be. I've had poor results with the atom graphics personally over several distributions.. what's the frame rate when you run glxgears ? – Elder Geek Oct 11 '14 at 17:02
  • The monitor refresh rate, 60 fps. – lemonsqueeze Oct 12 '14 at 14:12
  • whats the output of /usr/lib/nux/unity_support_test -p – Elder Geek Oct 13 '14 at 13:46
  • It doesn't have unity actually, it's xubuntu ... – lemonsqueeze Oct 13 '14 at 21:27
0

Finally found what's causing the issue:

  • Open CompizConfig Settings Manager
  • Select OpenGL plugin
  • Disable "Vertex buffer object" option:

Render all graphics primitives using vertex buffer objects (GL_ARB_vertex_buffer_object), if supported by the driver.
Pros: This provides higher graphics performance for some drivers.
Cons: This is a new feature and may cause graphical problems.
Note: This feature is always on in OpenGL|ES builds such as ARM platforms

Now textures display alright !

Looks like intel driver is not ready for this yet.

Also came across this thread:
If you care about performance it might be worth playing with the other OpenGL settings...

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.