1

I have a system where the Dash in Unity works as expected, but there is one specific file that.

  1. does not show up in the Dash home even after being just accessed

  2. if I search it in the dash home it does not show up, it's a JPG file

  3. if I search it in the document lens, it eventually appears, but it takes about a minute to appear, and sometimes it tells me it couldn't be found.

I have tried different things, like erasing the zeitgeist database, recreating the file, changing it a little bit with gimp. Short of reinstalling the whole system because of the cursed file, I think I have tried everything.

Surprisingly every other file or application that I access shows in the Dash Home as expected, but not this file.

If I search for the folder where this file is located, the Dash finds it.

Any hint on what is going on with this file?

  • It's hard to tell because we don't have access to the file itself, but maybe looking to see what is in the file itself might help. I'll pop an answer to show you how to do this. – hazrpg Oct 6 '14 at 10:10
0

Like I mentioned in the comments, the best way is to figure out if something strange is found in the EXIF segment of the JPG file. There are several tools, including online tools, available to help you do this. I'll show you how to use an online tool.

  1. Click on this link: Online Tool To Inspect EXIF of a JPG.
  2. Click on the button Choose file and pick the file you are having a problem with.
  3. Click on the View Image From File button to upload and have the file checked.
  4. You should see a preview of the image and a breakdown of the information found in the EXIF below it. See my example here.
  • I should point out, that if there is any strange things found in the EXIF, it might be worth taking those out. In that situation, this answer shows you how to: stackoverflow.com/a/2654314/3206232. Another thing I could suggest, if you are happy to share the file, then you could file a bug report against Unity on Launchpad to help the developers figure out if something in the file is causing Unity to crash - You can do so by going to: bugs.launchpad.net/unity/+filebug. I would be more than happy to create the bug report for you if you are happy to share the file with us. – hazrpg Oct 6 '14 at 10:30
  • Thanks @hazrpg. Just to clarify: 1) the file opens perfectly, there is nothing strange with it, just that the dash cannot find it, 2) unfortunately I can't share it, is a scan of some codes of my bank account, 3) if I enter in the dash the name of the folder where the file is located, the Dash finds the folder and it shows me the files in it, and there I can open the file without any problems, – wagafo Oct 7 '14 at 6:27
  • 4) if I search in the Documents lens, sometimes (not always) the file is found, but after about a minute of waiting, 5) this is my desktop, i have a laptop complete syncronized with this computer (same files syncronized with unison, same Ubuntu version) where the file is found immediately when I enter a couple of letters of the name of the file in the Dash search. – wagafo Oct 7 '14 at 6:32
  • That is so strange. Have you noticed this happening with any other files? Maybe it is a config issue somewhere... could you give us a bit more details about both the desktop and laptop, e.g. were they both clean installs? Did one (or both) get upgraded from a different version? – hazrpg Oct 7 '14 at 9:22
  • I've only seent it happening with this particular file, that's why I say it's cursed. These are upgraded systems, but in the system where I'm having this problem this has happened forever, I think the original install was 11.10 and I've been upgrading since. – wagafo Oct 9 '14 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.