7

Dropbox won't start, it was working fine until last week, so I tried to see what happens if i started it from terminal

Starting Dropbox...Dropbox isn't running!
Done!

If I try to run it again, it says

dropbox start
Dropbox is already running!
  • 1
    I don't know the answer, but I'd try renaming the the folder ~/.dropbox to something else to temporarily disable it, and see what happens. Also, look at the log files under that folder. – Marty Fried Oct 5 '14 at 18:47
  • 1
    @MartyFried seems like renaming that folder did the trick :D – Lynob Oct 5 '14 at 19:15
  • Great. Whenever reinstalling doesn't work, the next thing to try is the configuration files - I learned that with Firefox. – Marty Fried Oct 5 '14 at 19:24
  • @MartyFried hehe thats so true :) – Lynob Oct 5 '14 at 19:28
3

Naturally, it is easy to misinterpret statements, such as you read in terminal. Your 'dropbox start' statement, in fact, started Dropbox to running in the background! and the 'done' part of the statement only served to affirm that it is now running. The earlier part of the statement indicated that yes, dropbox start is a welcome order due to the fact that it is not yet running. Very simple, also very simple to misunderstand.

6

I have had the same problem when trying to run dropbox to a linux server. What was strange is it only happened when I had X11 forwarding on from putty (yet i had not installed X on the machine...)

Try to have X forwarding disabled (on putty do not check the X11 forwarding), it worked for me...

One note: try to also run .dropbox-dist/dropboxd directly, it might give you some hint on what is going on, such as if it has not yet registered the device.

  • Same here. Unfortunately, I wanted to use X11 forwarding for the GUI, so disabling it is not a solution... – Daniel Alder Jun 8 '15 at 20:22
  • I had no gui at the time, if you have a display manager, do try to check first that it is setup ok (e.g. run xterm).... Also, try connecting with ssh -Y instead of -X, sometimes it works better, take care though, its not as secure..... Last, I imagine you can start it from one window, exit and work from another :S – ntg Jun 9 '15 at 7:55
  • This is the solution for me! And now the message is no longer doubtful as it no longer tells me "Dropbox isn't running", it just says "Starting Dropbox...Done!" – scippie Sep 18 '16 at 18:12
1

The above solutions didn't help me. After a time-consuming debugging session I found two ubuntu packages which are important for Dropbox to work:

apt-get install libxslt1.1 libxxf86vm1

After installing them, the message when starting was (make sure there is no dropbox process running when starting):

user@xubuntu:~$ dropbox start
Starting Dropbox...Dropbox isn't running!
Done!

... which means (not obviously): success :-)

Btw: for thunar-dropbox-plugin (I mean for starting Thunar directly from the tray icon) you need at least the following extra packages:

apt-get install --no-install-recommends thunar-archive-plugin xdg-utils

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.