5

On my Asus N550KL laptop (running Ubuntu Gnome 14.04), my touchpad is detected as "PS/2 Logitech Wheel Mouse".

xinput outputs:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ PS/2 Logitech Wheel Mouse                 id=13   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Video Bus                                 id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ USB2.0 HD UVC WebCam                      id=10   [slave  keyboard (3)]
    ↳ Asus WMI hotkeys                          id=11   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=12   [slave  keyboard (3)]
  • FYI, this is an issue with more Asus laptop models. Last time I looked, a touchpad-specific driver was not yet written for this. – Lekensteyn Oct 23 '14 at 18:07
  • Thxs for the info, but can't this touchpad work with another touchpad driver? I don't know yet how drivers work and are coded, but I heard that there were just a few ones for a large ammount of existing hardware. Btw, I searched and couldn't find any drivers for ubuntu on the internet, only some sources for archlinux but it didnt compile with dkms build... – deb0ch Oct 25 '14 at 10:14
  • The problem with this specific hardware is that so far nobody has stepped up to write the driver. Does this help? askubuntu.com/questions/470388/… – Lekensteyn Oct 25 '14 at 11:14
  • It appears that there is some development activity for this device, see bugzilla.redhat.com/show_bug.cgi?id=1110011#c125 and github.com/mgottschlag/linux/commit/… for technical details. – Lekensteyn Oct 25 '14 at 12:54
  • We need to know which touchpad is used. It seems that OP had a Focaltech, but there could be others, like Elantech or Alps. – Pilot6 May 16 '15 at 22:15
4

There seem to be a duplicate of the question here:

Touchpad not recognized on Asus N550JK - TP500L (FocalTech)

but since the answer worked for me I will re-post it here:

I finally came to this bug report: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1372609

It seems FocalTech touchpad needs a specific driver, and that work is in progress to integrate it into the mainline kernel.

currently, there seem to be a ppa to get a dkms driver for this touchpad : http://ppa.launchpad.net/hanipouspilot/focaltech-dkms

After trying this, I can confirm the following procedure works :

1. add ppa:

`sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms`

2. update the packages database:

`sudo apt-get update`

3. install the dkms driver:

`sudo apt-get install focaltech-dkms`

4. reboot

The touchpad in now recognized. Two finger scrolling works, for example. Also, the zone where the buttons are won't make the cursor move.

Thanks for the community that retro-engeniered this (Asus just replied "no linux support nor technical information" to a request ! Very bad point to them (see the afore-mentioned bug report)).

(answered by alci, thanks a lot to you if you are reading me)


I just have a few things to add to this:

First, instead of rebooting, you can just run the following commands:

sudo modprobe -r psmouse
sudo modprobe psmouse

which will get it working just right =)

For those running Ubuntu 14.04:

I have not tested it myself, but the first command (sudo add-apt-repository ppa:hanipouspilot/focaltech-dkms) has a very nice verbose and explains the necessary steps for doing that on ubuntu 14.04, with the older kernel version.

| improve this answer | |
-1

Follow this step by step and you will get it working

Multitouch fix for Alps touchpad

Then execute these lines in terminal:

sudo update-initramfs -u
| improve this answer | |
  • I tried following that guide on 12.04, but I got this: make KERNELRELEASE=3.5.0-23-generic -C /lib/modules/3.5.0-23-generic/build M=/var/lib/dkms/psmouse/alps-1.3/build/src psmouse.ko....(bad exit status: 2) and then this: ERROR (dkms apport): binary package for psmouse: alps-dst-0.41 not found (I have an Asus X453MA) – joeytwiddle Jun 3 '15 at 11:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.