2

I have an Intel wireless 7260 AC adapter, I've had issus with wifi at work on this machine for a while. Very unstable connection, drops out very often. Tried updating everything. Currently on Ubuntu 14.10 with the 3.17 rc7 kernel. Also updated the firmware for the wifi adapter from the intel page.

Today i noticed something though, when I run

dmesg grep | iwl

I get

[    3.438189] iwlwifi 0000:02:00.0: irq 47 for MSI/MSI-X
[    3.439737] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-7260-10.ucode failed with error -2
[    3.439741] iwlwifi 0000:02:00.0: Falling back to user helper
[    3.728165] iwlwifi 0000:02:00.0: loaded firmware version 23.214.9.0 op_mode iwlmvm
[    3.768835] iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 7260, REV=0x144
[    3.768889] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    3.769104] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    3.974657] ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
[    3.977897] iwlwifi 0000:02:00.0 wlan1: renamed from wlan0
[    5.363472] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[    5.363693] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[  436.522290] iwlwifi 0000:02:00.0: No association and the time event is over already...
[  995.642105] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[  995.642334] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 1050.138120] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 1050.138361] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 2212.961499] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 2212.961720] iwlwifi 0000:02:00.0: L1 Disabled; Enabling L0S
[ 2220.592704] iwlwifi 0000:02:00.0: No association and the time event is over already...

In the second line of the dmesg it tries to load the firmware 7260-10.ucode and it doesn't exist in /lib/firmware/, only 7260-7.ucode, 7260-8.ucode and 7260-9.ucode is there.

Is there a way to set what firmware is loaded, latest recommended from Intel is 7260-8.ucode, or am I missing the 7260-10.ucode firmware?

2

You are missing the experimental -10 firmware. The driver accepts several versions, if available. Failing to find -10, it found and loaded -9:

loaded firmware version 23.214.9.0 op_mode iwlmvm

In this context, the .9 refers to the -9 firmware. I am not sure where the -10 firmware is even available.

There are a limited number of things to try to help stability aside from settings in the router. I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=8

If it helps, make it permanent:

sudo -i
echo "options iwlwifi 11n_disable=8"  >>  /etc/modprobe.d/iwlwifi.conf
exit

If you'd like to try to disable N capability completely, then do:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

Use nano or kate or leafpad if you don't have the text editor gedit. Change the last line that currently reads: 'options iwlwifi 11n_disable=8' so that is now reads:

options iwlwifi 11n_disable=2

Proofread carefully, save and close the text editor. Reboot.

10
  • 1
    I actually found the -10 firmware here: wireless.kernel.org/en/users/Drivers/iwlwifi it's the Core 7 experimental branch. It doesn't seem to help though, it's still unstable, almost unusable. I think I'll try the -7 and -8 firmwares and see if that helps. – artothief Oct 5 '14 at 16:08
  • Since you already have the -7 and -8 on your system, you may be able to force the driver to select the one you wish to try by renaming the others, for example, sudo mv iwlwifi-7260-9.ucode iwlwifi-7260-9.bak. – chili555 Oct 6 '14 at 14:13
  • 1
    I've tried the different firmwares now, and -7 is dead,no wifi. The rest (-8 through -10) is more or less the same. However after using it a day it seems the -10 is more stable. I suspect it might be a frequency issue, because when I run iwconfig, sometimes it says it's a 5.28 ghz network and other times a 2.43 ghz network. Now it says 5.28 ghz, but I very much doubt we have that frequency on here, but I have no access to the router so it's difficult to check. – artothief Oct 6 '14 at 15:39
  • Please see my edit above. – chili555 Oct 6 '14 at 17:26
  • Well, after days of tinkering this is what I've found: Even though the connection is locked to the 2.4Ghz G protocol, it will sometimes connect to the 5ghz A protocol. This will in return result in a very bad connection. If I go to the network manager and press the arrow on the left of the connected network it will tell me it is not connected and if I press connect it will re-connect to the 2.4Ghz frequency and the connection is good again. Haven't found an option anywhere to disable either 5Ghz or the A protocol, is this possible without enabling Ad-hoc mode which also breaks the connection? – artothief Oct 9 '14 at 18:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.