I hope this question is appropriate for this forum. I have an embarrassing problem. After trying to get Ekiga-Softfon running I suddenly have no sound anymore at all. But I can't tell how I caused this problem anymore.

Below I have collected some relevant information:

lsb_release -d
Description:    Ubuntu 10.04.1 LTS

uname -r

cat /proc/asound/cards
 0 [ICH6           ]: ICH4 - Intel ICH6
                      Intel ICH6 with STAC9752,53 at irq 16

aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: ICH6 [Intel ICH6], Gerät 0: Intel ICH [Intel ICH6]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: ICH6 [Intel ICH6], Gerät 4: Intel ICH - IEC958 [Intel ICH6 - IEC958]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

aplay /usr/share/sounds/alsa/Noise.wav
Wiedergabe: WAVE '/usr/share/sounds/alsa/Noise.wav' : Signed 16 bit Little Endian, Rate: 48000 Hz, mono

lspci -nnk | grep -iA2 audio 
00:1e.2 Multimedia audio controller [0401]: Intel Corporation 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller [8086:266e] (rev 03)
    Kernel driver in use: Intel ICH
    Kernel modules: snd-intel8x0

ps -C esd
  PID TTY          TIME CMD

ps -C arts
  PID TTY          TIME CMD

ps -C pulseaudio
  PID TTY          TIME CMD
 1239 ?        00:00:00 pulseaudio

grep "^audio" /etc/group | grep "$USER" | wc -l

lsmod | grep "snd"
snd_intel8x0           25588  1 
snd_ac97_codec        100646  1 snd_intel8x0
ac97_bus                1002  1 snd_ac97_codec
snd_pcm_oss            35308  0 
snd_mixer_oss          13746  1 snd_pcm_oss
snd_pcm                70694  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy           1338  0 
snd_seq_oss            26726  0 
snd_seq_midi            4557  0 
snd_rawmidi            19056  1 snd_seq_midi
snd_seq_midi_event      6003  2 snd_seq_oss,snd_seq_midi
snd_seq                47263  6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              19098  2 snd_pcm,snd_seq
snd_seq_device          5700  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    54148  12 snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore               6620  1 snd
snd_page_alloc          7076  2 snd_intel8x0,snd_pcm

head -n 3 /proc/asound/card0/codec#0
head: „/proc/asound/card0/codec#0“ kann nicht zum Lesen geöffnet werden: No such file or directory

head -n 3 /proc/asound/card0/codec97#0/ac97#0-0
0-0/0: SigmaTel STAC9752,53

PCI Subsys Vendor: 0x1028

head -n 3 /proc/asound/card0/codec97#0/ac97#0-0+regs
0:00 = 6a90
0:02 = 0000
0:04 = 0000

asoundconf list
asoundconf: Befehl nicht gefunden

cat ~/.asoundrc
pcm.pulse { type pulse }
ctl.pulse { type pulse }

cat ~/.asoundrc.asoundconf
cat: /home/rasmus/.asoundrc.asoundconf: No such file or directory

There are some bits of German: "Befehl nicht gefunden" means "command not found", "kann nicht zum Lesen geöffnet werden" means "cannot be opened for reading".

I'd appreciate any help.


Yeah, I agree with koanhead. Double check your hardware, try rebooting of course and check alsamixer. You can just type in "alsamixer" in the terminal and check all the settings. There's also a graphical front end available from the software center. You should be able to find it by searching for "alsamixer" in the software center.

  • Thanks to both of you. If had messed up the hardware settings. Problem solved. – Rasmus Oct 9 '10 at 9:42

I don't see anything in those listings that would cause such a problem so far as I can see.

However, just to be complete, let me ask: Did you check your mixer settings? Nothing is muted?

Do you have a Live CD handy with which to test the audio? My audio recently flaked out and I spent a bunch of time troubleshooting before I discovered it was a hardware problem (chipset fan died causing overheating; adding a fan fixed all symptoms).

The thing I find most suspicious is that the aplay command apparently worked without error, yet you didn't hear the sound.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.