1

I cannot access any Google services such as Google.com or GMail from my Ubuntu 14.04. It's not an ISP issue, because I can access Google services using my smartphone using the same wifi connection that connects my PC.

If I try to access google.com or mail.google.com with Chromium browser, it keeps loading with "resolving host" at the status bar. If I leave it to load, after a long time it returns an empty blank white page with no error messages.

    jouni@OmniCorp:~$ host google.com
    google.com has address 173.194.126.35
    google.com has address 173.194.126.36
    google.com has address 173.194.126.32
    google.com has address 173.194.126.41
    google.com has address 173.194.126.38
    google.com has address 173.194.126.46
    google.com has address 173.194.126.39
    google.com has address 173.194.126.37
    google.com has address 173.194.126.34
    google.com has address 173.194.126.33
    google.com has address 173.194.126.40
    google.com has IPv6 address 2404:6800:4001:801::1000
    google.com mail is handled by 20 alt1.aspmx.l.google.com.
    google.com mail is handled by 30 alt2.aspmx.l.google.com.
    google.com mail is handled by 40 alt3.aspmx.l.google.com.
    google.com mail is handled by 50 alt4.aspmx.l.google.com.
    google.com mail is handled by 10 aspmx.l.google.com.

    jouni@OmniCorp:~$ ping google.com
    PING google.com (173.194.126.40) 56(84) bytes of data.
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=1 ttl=55 time=36.8 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=2 ttl=55 time=38.0 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=3 ttl=55 time=40.5 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=4 ttl=55 time=40.3 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=5 ttl=55 time=42.7 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=6 ttl=55 time=35.6 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=7 ttl=55 time=36.5 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=8 ttl=55 time=35.7 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=9 ttl=55 time=47.0 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=10 ttl=55 time=35.4 ms
    64 bytes from kul01s08-in-f8.1e100.net (173.194.126.40): icmp_seq=11 ttl=55 time=35.4 ms
    ^C
    --- google.com ping statistics ---
    11 packets transmitted, 11 received, 0% packet loss, time 9995ms 
    rtt min/avg/max/mdev = 35.472/38.595/47.012/3.544 ms

I get Google services to work in my Ubuntu computer if I run

    sudo service network-manager restart

After this, Google services work for a few minutes. This problem has been going on for a few weeks now.

Any ideas?

1

I had the same problem. I went through these steps and solved it:

  1. Edit ...
vi /etc/ppp/peers/dsl-provider
  1. By #, comment this line like this:
#usepeerdns
  1. Edit ...
vi /etc/resolvconf/resolv.conf.d/head
  1. Make sure it is like this:
nameserver 8.8.8.8

By the way, my connection was pppoe. If you can manage where usepeerdns is for wifi, yours also will be solved.

| improve this answer | |
0

May be your ISP DNS server goes weird. Or your router's. First of all, check if you can ping 8.8.8.8. If yes, go to network settings and set DNS to manual 8.8.8.8. If it already is, set it to 77.88.8.8

| improve this answer | |
  • I can ping 8.8.8.8 and I have now put it as my DNS, but that does not help. Same problem still persists. Same with 77.88.8.8. I also downloaded Firefox to ensure it's not a Chromium problem and the same problem with Firefox. It's not the browser either... – user254173 Oct 5 '14 at 22:53
0

Edit /etc/NetworkManager/NetworkManager.conf with vim or gedit

Hash(#) out (comment out) the line dns=dnsmasq

It should look like this

[main] plugins=ifupdown,keyfile

#dns=dnsmasq

[ifupdown] managed=false

Then do the following;

sudo /etc/init.d/nscd restart

sudo service network-manager restart
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.