I have extracted down Extreme tux racer in my home folder, after extracting it in same folder, i run commands-


then following commands run-

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for g++... no
checking for c++... no
checking for gpp... no
checking for aCC... no
checking for CC... no
checking for cxx... no
checking for cc++... no
checking for cl.exe... no
checking for FCC... no
checking for KCC... no
checking for RCC... no
checking for xlC_r... no
checking for xlC... no
checking whether the C++ compiler works... no
configure: error: in `/home/username/game':
configure: error: C++ compiler cannot create executables
See `config.log' for more details

What is the problem and what are the solution for this? http://sourceforge.net/projects/extremetuxracer/ I have files saved on my hdd, so i am not wanting to download from Ubuntu app store

  • As you can see, there is no c++ compiler installed in your system. First installed a compiler like g++, or better install build-essential package using sudo apt-get install build-essential
    – g_p
    Oct 5, 2014 at 11:06
  • when i run sudo apt-get install gcc , it is already in it's newest version, what should i run? Oct 5, 2014 at 11:07
  • @aVIRA sudo apt-get install build-essential, as g_p has already stated.
    – muru
    Oct 5, 2014 at 11:20
  • it is too in latest version Oct 5, 2014 at 11:23

2 Answers 2


Extreme Tux Racer is in Official Ubuntu Repository.

You can install it without difficult compilations by:

sudo apt-get install extremetuxracer

Well, one simple way is :

  1. Open Ubuntu Software Center

  2. Search for, Extreme Tux Racer

  3. Install, by clicking the install button provided.


1. Unpack the code tarball:

shell$ tar xvfz tuxracer-<version>.tar.gz
shell$ cd tuxracer-<version>

2. Configure for your system:

shell$ ./configure <configure options>

Many people will be able to run configure without passing any options. The more commonly-used configure options are:

--prefix=DIR: Specify where to install tuxracer. (The tuxracer binary will be placed in DIR/bin) --with-tcl-libs=DIR: Specify Tcl library location --with-tcl-inc=DIR: Specify Tcl header file location --with-tcl-lib-name=NAME: Specify Tcl library base name --with-gl-libs=DIR: Specify OpenGL library location --with-gl-inc=DIR: Specify OpenGL header file location --with-glut-libs=DIR: Specify GLUT library location --with-glut-inc=DIR: Specify GLUT header file location --enable-stencil-buffer: Use if your hardware has a stencil buffer --with-data-dir=PATH: Location of tuxracer data directory (can be also configured in options file later)

Run ./configure --help for a complete list of options.

3. Compile:

shell$ make

Tux Racer should compile cleanly, with few (if any) warnings. Please see the FAQ#compilation or our Support page if Tux Racer fails to compile.

4. Install the tuxracer binary:

shell$ make install

Unless you specified the --prefix option when you ran configure, this command will install the tuxracer binary in /usr/local/bin

5. Install the data files:

shell$ cd /usr/local/share
shell$ tar xvfz /path/to/tuxracer-data-<version>.tar.gz
shell$ mv tuxracer-data-<version> tuxracer

You may install the data files anywhere you wish, but tuxracer looks in /usr/local/share/tuxracer by default.

6. You're done!

  • whole package it in my hdd. That's why I am not wanting to install from software centre Oct 5, 2014 at 10:58
  • @aVIRA package will automatically be downloaded, extracted and installed for you by the software center.
    – devGeek
    Oct 5, 2014 at 11:00
  • Sir, all I am asking is, is there anything I am missing or anything could be done for installing it. If i started download it would take 5-6 hrs., because transfer rate is very slow at my area. Oct 5, 2014 at 11:02
  • after running command make, it shows error - make: *** No targets specified and no makefile found. Stop. Oct 5, 2014 at 11:38
  • @aVIRA Click on the FAQ#compilation link under the Compile section.
    – devGeek
    Oct 5, 2014 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.