1
 root@server:~# postconf -n
    append_dot_mydomain = no
    biff = no
    broken_sasl_auth_clients = yes
    config_directory = /etc/postfix
    disable_vrfy_command = yes
    dovecot_destination_recipient_limit = 1
    inet_interfaces = all
    mailbox_size_limit = 0
    message_size_limit = 0
    mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128, 144.122.116.0/24


   mynetworks_style = host
    myorigin = /etc/mailname
    queue_directory = /var/spool/postfix
    readme_directory = no
    recipient_delimiter = +
    relayhost = [smtp.buyorsell.it]:587
    smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
    smtp_use_tls = yes
    smtpd_banner = $myhostname ESMTP $mail_name
    smtpd_delay_reject = yes
    smtpd_helo_required = yes
    smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, rej                                             ect_unauth_destination
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_path = private/auth
    smtpd_sasl_security_options = noanonymous
    smtpd_sasl_type = dovecot
    smtpd_sender_restrictions = permit_sasl_authenticated, permit_mynetworks,permit
    smtpd_tls_cert_file = /etc/ssl/certs/smtpd.cert
    smtpd_tls_key_file = /etc/ssl/private/smtpd.key
    smtpd_tls_security_level = may
    smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
    smtpd_use_tls = yes
    virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf
    virtual_mailbox_base = /var/vmail
    virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
    virtual_mailbox_limit = 0
    virtual_mailbox_maps = proxy:mysql:$config_directory/mysql-virtual-mailbox-maps.                                             cf
    virtual_transport = dovecot

and

root@server:~# dovecot -n
# 2.0.19: /etc/dovecot/dovecot.conf
doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/10-master.conf:124: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in /etc/dovecot/conf.d/10-master.conf:124: add auth_ prefix to all settings inside auth {} and remove the auth {} section completely
# OS: Linux 2.6.32-042stab088.4 x86_64 Ubuntu 12.04.5 LTS simfs
auth_mechanisms = plain login
disable_plaintext_auth = no
mail_location = maildir:/var/mail/vhosts/%d/%n
mail_privileged_group = mail
managesieve_notify_capability = mailto
managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date ihave
passdb {
  args = /etc/dovecot/dovecot-sql.conf.ext
  driver = sql
}
plugin {
  sieve = ~/.dovecot.sieve
  sieve_dir = ~/sieve
}
protocols = imap pop3 sieve
service auth-worker {
  user = vmail
}
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0660
    user = postfix
  }
  unix_listener /var/spool/postfix/private/dovecot-auth {
    group = postfix
    mode = 0660
    user = postfix
  }
  unix_listener auth-userdb {
    mode = 0600
    user = vmails
  }
  user = dovecot
}
service imap-login {
  inet_listener imap {
    port = 143
  }
  inet_listener imaps {
    port = 993
    ssl = yes
  }
}
service lmtp {
  unix_listener /var/spool/postfix/private/dovecot-lmtp {
    group = postfix
    mode = 0600
    user = postfix
  }
}
ssl_cert = </etc/ssl/certs/dovecot.pem
ssl_key = </etc/ssl/private/dovecot.pem
userdb {
  args = /etc/dovecot/dovecot-sql.conf.ext
  driver = sql
}
protocol imap {
  imap_client_workarounds = delay-newmail
  mail_max_userip_connections = 10
}
protocol pop3 {
  mail_max_userip_connections = 10
  pop3_client_workarounds = outlook-no-nuls oe-ns-eoh
}
protocol lda {
  deliver_log_format = msgid=%m: %$
  mail_plugins = sieve
  postmaster_address = postmaster
  quota_full_tempfail = yes
  rejection_reason = Your message to <%t> was automatically rejected:%n%r
}
  • Try adding smtpd_sasl_path = inet:127.0.0.1:12555 for postfix to pass the sasl auths to dovecot. – douggro Oct 5 '14 at 7:53
  • @ douqqro not worked – Muhammad Muazzam Oct 5 '14 at 8:24
  • Did you get this configuration from a tutorial? Is Dovecot set up? Have you checked the Postfix and Dovecot documentation to make sure that the configuration parameters are correct? My comment was based on not seeing an avenue for Postfix to pass the auths to Dovecot. You may have to set a port(the 12555 in my sample) for Dovecot to get the requests. – douggro Oct 5 '14 at 8:51
  • @douggro please look into the dovecot configuration – Muhammad Muazzam Oct 5 '14 at 9:28
1

corrected user in one of the dovecot configuration to:

  unix_listener auth-userdb {
    mode = 0600
    user = vmail
  }
0

From http://www.postfix.org/SASL_README.html#client_sasl_policy

I had to run

$ sudo cp /usr/lib/x86_64-linux-gnu/sasl2/libplain.so.2.0.25 /usr/lib/sasl2/libplain.so $ sudo systemctl restart postfix

on zesty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.