6

I am getting this error sometimes when I resume from hibernation. All of my open windows are closed. There is also an extra reboot before it will actually get to the login screen.

The title of the error as seen in Apport is [Gigabyte Technology Co., Ltd. To be filled by O.E.M.] hibernate/resume failure [non-free: nvidia]

The annotation says This occured during a previous hibernate and prevented it from resuming properly.

ExecutablePath: /usr/share/apport/apportcheckresume

Architecture: amd64

DistroRelease: Ubuntu 14.04

Failure: hibernate/resume

Tags: resume hibernate trusty

CRDA:

country 00:
  (2402-2472 @ 40), (6,20)
  (2457-2482 @ 40), (6, 20), PASSIVE-SCAN, NO-IBSS
  (2474-2494 @ 20), (6,20), NO-OFDM, PASSIVE-SCAN, NO-IBSS
  (5170-5250 @ 160), (6,20), PASSIVE-SCAN, NO-IBSS
  (5250-5330 @ 160), (6,20), DFA, PASSIVE-SCAN, NO-IBSS
  (5490-5730 @ 160), (6,20), DFS, PASSIVE-SCAN, NO-IBSS

The https://wiki.ubuntu.com/DebuggingKernelHibernate page isn't helping. My problem doesn't seem to be there. This is not a problem with encrypted swap. It is not encrypted.

I do have an Nvidia GTX 670.

  • If the issues persist after the previous answer try <br>askubuntu.com/a/491872 <br>It worked for me. – user382716 Feb 26 '15 at 10:29
2
+50

Unfortunately, hibernate doesn't work in many cases, which can cause you to lose data if you expect your documents and applications to re-open when you switch your computer back on. Therefore, hibernate is disabled by default.

Test if hibernate works

Note : Always save your work before hibernating
You should save all of your work before hibernating the computer, just in case something goes wrong and your open applications and documents cannot be recovered when you switch on the computer again.

You can use the command line to test if hibernate works on your computer.

  1. Open the Terminal by pressing Ctrl+Alt+T or by searching for terminal in the Dash.

  2. Type sudo pm-hibernate into the terminal and press Enter.
    Enter your password when prompted.

  3. After you computer turns off, switch it back on. Did your open applications re-open?

If hibernate doesn't work, check if your swap partition is at least as large as your available RAM.

Enable hibernate

If the hibernate test works, you can continue to use the sudo pm-hibernate command when you want to hibernate.

You can also enable the hibernate option in the menus. To do that, use your favorite text editor to create /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla. Add the following to the file and save:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate; org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes

Restart and hibernation is back!

Or run killall unity-panel-service to just reset the menu.

Some users will then need to run sudo update-grub to get the hibernate option to be available in the power menu. Some users may also have to at least log out then log in to get it to appear in the (upper right) power menu.

Source : Official Documentation

0

I solved the same problem temporarily in Ubuntu 16.04 by changing the video driver from NVIDIA driver version 384.130 to X.Org X server - Nouveau driver(in 'additional drivers'). God bless us.


Update: It also works with the 418.56 NVIDIA driver.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.