This question already has an answer here:

Just couple minutes ago I tried to install Latest Nvidia Driver 340.46 via PPA in Ubuntu. For this reason I used this instruction

The following commands weere executed:

sudo add-apt-repository ppa:mamarley/nvidia

sudo apt-get update

sudo apt-get install nvidia-340

After reboot I see only black screen and that all.

How can I fix it?

marked as duplicate by Eliah Kagan, devWeek, Sylvain Pineau, Kaz Wolfe, Eric Carvalho Oct 6 '14 at 1:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • can you switch to tty by pressing ctrl + alt + F1 ? or this is only black screen with blinking cursor ? – EdiD Oct 4 '14 at 20:37
  • 1
    @EdiD, yes,this is only black screen with blinking cursor. – user471011 Oct 4 '14 at 21:59
up vote 4 down vote accepted

If you can't switch to tty by ctrl + alt + F1 combination you have to launch rescue mode. You can do it by holding shift after post test (before ubuntu start launching). Now select you want to have network connection and go to root command. You have to remount your drive from read only to full access:

mount -o remount,rw /

Now purge your current nvidia drivers installation by:

apt-get purge nvidia*

and restore older driver:

apt-get install nvidia-current

Now you can try to reboot.
(and in farther way install e.g nvidia 331 drivers)

It Could Be a package problem or driver problem.

Change to tty

ctrl+alt+F1

Try to remove the xorg.conf file by doing in the termial the following command: sudo rm /etc/X11/xorg.conf Then try to create a new on by doing in the termial the following command: sudo nvidia-xconfig

If still dont work remove the driver and install the normal.

sudo apt-get --purge remove --purge nvidia-* // note this command will also remove the ubuntu-desktop package!!!

After: sudo apt-get install ubuntu-desktop

Final: apt-get install nvidia-331 nvidia-331-dev nvidia-331-uvm nvidia-settings

Not the answer you're looking for? Browse other questions tagged or ask your own question.