3

I have Ubuntu 14.04 LTS. Every time I press the volume up/down/mute button on my keyboard, this box appears in the top right corner of my screen telling me the current volume level. Is there any way to disable that box from appearing?

1

AFAIK, this is option is not available as user configuration. You need to change & rebuild source of media-keys.gnome-settings-plugin (libmedia-keys.so) from unity-settings-daemon package.

If you want disable all notification, then this is a duplicate. See How can I customize/disable notification bubbles?

I'm using Ubuntu 14.04 64bit.

  1. Download build dependences & source:

    sudo apt-get build-dep unity-settings-daemon
    apt-get source unity-settings-daemon
    
  2. Modify gsd-media-keys-manager.c to disable volume notification only

    unity-settings-daemon-14.04.0+14.04.20140606/
    nano plugins/media-keys/gsd-media-keys-manager.c
    

    Use // to comment those two lines then return TRUE;:

    static gboolean
    ubuntu_osd_notification_show_volume (GsdMediaKeysManager *manager,
                                         gint value,
                                         gboolean muted)
    {
            //return ubuntu_osd_do_notification (&manager->priv->volume_notification,
            //                                   "volume", value, muted, volume_icons);
            return TRUE;
    }
    
  3. Compile & replace the one from repository:

    ./autogen.sh
    make
    sudo cp /usr/lib/unity-settings-daemon-1.0/libmedia-keys.so /usr/lib/unity-settings-daemon-1.0/libmedia-keys.so.backup
    sudo rm /usr/lib/unity-settings-daemon-1.0/libmedia-keys.so
    sudo cp ./plugins/media-keys/.libs/libmedia-keys.so /usr/lib/unity-settings-daemon-1.0/libmedia-keys.so
    restart unity-settings-daemon
    

How did I find it:

  1. dbus-monitor
  2. Click on volume media key, watch for the sender of notification call
  3. You may see only as number (Ex: :1.14), use qdbusviewer to know name:

    method call sender=:1.14 -> dest=:1.107 serial=176 path=/org/freedesktop/Notifications; interface=org.freedesktop.Notifications; member=Notify
       string "gnome-settings-daemon"
       uint32 0
       string "notification-audio-volume-medium"
       string " "
       string ""
       array [
       ]
       array [
          dict entry(
             string "x-canonical-private-synchronous"
             variant             string "volume"
          )
          dict entry(
             string "value"
             variant             int32 44
          )
       ]
       int32 -1
    
  4. Now, you get the related package, report a bug!!! Changing Code is just an art, try it yourself. I'm not an alien.

0

Install NotifyOSDConfig, the GUI used to configure the NotifyOSD.

Then lets add it's PPA. Open a Terminal and type the command.

sudo add-apt-repository ppa:nilarimogard/webupd8 

Next update list and start installation

sudo apt-get update
sudo apt-get install notifyosdconfig

And How did I disable it?

Launch NotifyOSD Configuration from Dash and as you see in screenshot you need to change "Width" and "Corner Radius" to "0 px" and then click Apply.

enter image description here

Enjoy ;)

  • Wait, won't this disable all notification bubbles? I don't see anything in this answer that should make this apply only to volume notifications. – Mark Amery Sep 20 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy