I've a windows shared folder which I can access by typing \\share\files\ in "run".

I need to use that in Ubuntu. So I added \\share\files\ /mnt/share/ cifs guest,uid=0,iocharset=utf8 0 0 in /etc/fstab.
And then issued mount -a. I got directory not resolvable error mount error: could not resolve address for share: Unknown error.

I'm pretty new here, can you please help me?

Edit 1: I tried adding //share/files/ /mnt/share/ cifs guest,uid=0,iocharset=utf8 0 0 in /etc/fstaband issuing mount -a command and got same error.

I used id -u and got 0, used that in uid=0.

Edit 2

I used IP (// /mnt/share/ cifs guest,uid=0,iocharset=utf8 0 0) instead of directory path and got the following error message

Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
  • 1
    I think that should be all forward slashes? See wiki.archlinux.org/index.php/samba#Add_Share_to_.2Fetc.2Ffstab
    – Brian Z
    Oct 4, 2014 at 3:54
  • Related (but probably not really a duplicate): Proper fstab entry to mount a samba share on boot? Oct 4, 2014 at 4:07
  • I just tried using forward slashes with same error. Any other idea?
    – IFightCode
    Oct 4, 2014 at 4:39
  • Then edit you question so that it is clear what you tried!! Oct 4, 2014 at 5:03
  • 1
    Is the Guest account enabled on the Windows machine? If not, then you will need to provide credentials for this to work. If the Guest account is not enabled and you can connect to the share from another Windows machine without supplying credentials then in that case you are (implicitly) using pass-through authentication. Oct 4, 2014 at 8:11

1 Answer 1


To mount a share via fstab, you should:

  • create a mount point (directory) to mount the share into. I am not sure if /mnt/share/ exists?
  • use forward slash
  • add the ip address of the share before the share name in the fstab file.
  • if not installed already: install cifs utils
  • for a guest account (unprotected share), you should use guest,uid=1000 as user id, to make the guest owner.
  • to enter a password protected share, you need to set the user id to the share's user name and the reference to a credentials file (see example below)

As an example, my line in the fsatb file looks like (the \040 is an escape for the space):

//\040Jacob /home/jacob/Netwerkmap cifs auto,iocharset=utf8,uid=jacob,gid=users,credentials=/root/.cifscredentials,file_mode=0775,dir_mode=0775 0 0
  • I updated question, can you please check one more time?
    – IFightCode
    Oct 4, 2014 at 7:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.