While I have a nautilus window open I can do Ctrl+Shift+N to create a new folder in the current directory. However there is no default keyboard shortcut for creating a new document. How would I create one?

3 Answers 3


First, open gconf-editor and set /desktop/gnome/interface/can_change_accels to true. This lets you edit menu shortcuts.

Second, open a terminal and type: killall nautilus && UBUNTU_MENUPROXY= nautilus This will relaunch Nautilus with the standard (non-Unity) menu bar, because the Unity menu bar doesn't support this feature. (It will respect your changed shortcuts, but it won't let you change them.)

Now, open the file menu, hover the mouse over Create Document > Empty File and press your desired shortcut. Ctrl-Alt-N seems like a decent choice, or you can reassign Ctrl-N. You should see the accelerator hint change in the menu.

Finally, relaunch Nautilus without the UBUNTU_MENUPROXY variable to get your Unity menus back with the new shortcut.

Edit: The solution for newer versions is nearly the same , except you need to use dconf-editor instead of gconf-editor. You can install the dconf-tools package to get dconf-editor.

Also, the killall nautilus ... command did not appear to be necessary.

  1. Run dconf-editor.
  2. Go to org/gnome/desktop/interface.
  3. Check the box for can-change-accels.
  4. Open Nautilus and highlight the menu item whose key binding you want to change, either with your mouse or via the keyboard, and press the key(s) you want to use as the shortcut.
  5. Don't forget to uncheck can-change-accels in dconf-editor after you're done.
  • killall nautilus && UBUNTU_MENUPROXY= nautilus that for some reason did not relaunch nautilus with non-unity menu bar for me. I had to login in classic mode. But worked. :)
    – shxfee
    Jul 15, 2011 at 19:52
  • is it possible via a single bash script?
    – disfated
    Jan 7, 2012 at 22:27
  • Anyway to do this in 12.04? I'm getting stuck at step two. No process named nautilus is found.
    – Kelbizzle
    Aug 6, 2012 at 7:19
  • For 12.04 see my answer here: askubuntu.com/q/88010
    – stevelove
    Aug 7, 2012 at 1:51
  • Appreciate the edit, however if you are using unity, I think it's still necessary to relaunch nautilus with the global menu bar disabled: the hover-and-press-shortcut behaviour doesn't work on the unity menus.
    – cscarney
    Mar 13, 2013 at 3:07

Open terminal:gconf-editor

go to


find unassigned command e.g. command_1

double click on value and type /usr/bin/gedit

next step go to


select run_command_1 (in this example) , double click on the value and set the preferred shortcut

Logout/Login from/to system

  • wouldnt this simply open Gedit?
    – shxfee
    Jul 15, 2011 at 19:43
  • this will open new document with gedit, the document must be saved after finishing of work
    – petrakis
    Jul 15, 2011 at 19:48
  • not what i wanted. thank a bunch though.
    – shxfee
    Jul 15, 2011 at 19:54

On Ubuntu 16.04, I tried to change the accels by hovering-and-pressing-shortcut but it didn't seem to work. Then it dawned upon me, "Hey, why not use the default accels?!" And it worked perfectly for me.

So here's how to do it.

  1. Press Alt + F to open the File menu.
  2. Press D to go-to the New Document sub-file menu.
  3. Press E to create a new document.

If you just press it rapid succession, it feels almost like a keyboard shortcut. Press Alt + F, then immediately D and immediately after that E. Boom. You're welcome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .