9

I've noticed on the Desktop version when typing commands like sudo apt-get install mysq I can tab complete like when resolving file paths. However in the server edition this does not happen. Is there a package I need for this, or a configuration file to make this happen?

11

That's strange, maybe package bash-completion is what you're looking for?

2

Check your ~.bashrc file. Last para of mine reads as follows:

# enable programmable completion features (you don't need to enable

# this, if it's already enabled in /etc/bash.bashrc and /etc/profile

# sources /etc/bash.bashrc). if [ -f /etc/bash_completion ] && ! shopt -oq posix; then . /etc/bash_completion fi

This is unmodified from the originally installed (desktop edition) file. Obviously if the section starting with if and ending with fi is commented out, then you won't get completion. Also check the other listed file locations of course.

0

I strongly recommend you to check zsh

you can simply intall it with

sudo apt-get install zsh

it's better than bash, and it has a lot of great customizations

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.