7

I don't want Super + L (that is the windows key pressed with the L key) to lock my screen. I have disabled this in settings, but it still happens. How do I make this not happen?

enter image description here

| improve this question | | | | |
  • 3
    what is your output of gsettings get org.gnome.desktop.lockdown disable-lock-screen? I can disable it by gsettings set org.gnome.desktop.lockdown disable-lock-screen true, but the screen still turns black for a while... – Jacob Vlijm Oct 3 '14 at 16:55
  • 1
    Are you using Unity or Gnome Shell? They both have their own problems with hard to remove default keyboard short cuts. – David Foerster Oct 3 '14 at 17:00
  • @DavidFoerster I am using Unity. I updated my question title. – kzh Oct 3 '14 at 18:03
  • Some may think that this is a duplicate of askubuntu.com/q/17157/1879 , but I don't think that it is although it has the same solution. What do other members of the community think? – kzh Oct 3 '14 at 18:07
  • @kzh: Can you include the info about your desktop environment in you question please? It may be relevant for people who know the answer or have the same problem. – David Foerster Oct 3 '14 at 18:17
7

You should be able to see what is the current setting by the command:

gsettings get org.gnome.desktop.lockdown disable-lock-screen

The output should be:

true

If it isn't, you can set it by the command:

gsettings set org.gnome.desktop.lockdown disable-lock-screen true

A cosmetic downside on my system is however that the screen doesn't lock any more, but still turns black for a second or so. You'll have to see if it works well on your system.

| improve this answer | | | | |
  • This does the trick. I assume that the answer is yes, but are these changes persistent? – kzh Oct 3 '14 at 18:18
  • @kzh Yes, the change is persistent. – Radu Rădeanu Oct 3 '14 at 18:19
  • @kzh on my system it is, let me know if it isn't, I'll make a workaround – Jacob Vlijm Oct 3 '14 at 18:20
  • @JacobVlijm Thanks for the offer, but I think that it is persistent and if not, I am sure I can come up with something. – kzh Oct 3 '14 at 18:24
  • This is only a half-way solution. The black screen is not helpful. What worked (in 16.04 LTS) was disabling the shortcut through the Compiz config: stackoverflow.com/a/26224554/200987 – oligofren May 29 '17 at 10:23
5

A fix on Ubuntu 16.04 that does not turn your screen black is disabling the key setting using the Compiz configuration manager. Turns out it is not Gnome, but Compiz, that captures the key combo. This is why disabling the shortcut does not work. This Stack Overflow question covers how to do it.

The package is called compizconfig-settings-manager and I only managed to find it using the GUI app launcher. To reproduce the steps here:

  • Install and run CompizConfig Settings Manager
  • Click "Ubuntu Unity Plugin"
  • Click the button next to "Key to lock the screen."
  • Disable
| improve this answer | | | | |
  • Works great without the black screen flash! next I just need to find out what it is setting so I can just configure it via vim or emacs or from the command line – Silfheed Jul 24 '18 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.