1

Ubuntu 14.04 LTS on this laptop once booted works all right. However, the boot itself is a gamble. I often have to make many tries to get it to boot successfully. It can get stuck at unpredictable points during boot.

Any help will be appreciated.

1
2

I have the exact same laptop, and I found the following: http://en.community.dell.com/support-forums/laptop/f/3518/t/19595872

Basically, add the following two lines to /etc/modprobe.d/blacklist.conf:

blacklist dw_dmac
blacklist dw_dmac_core

That fixed it for me, and now it works perfectly.

While I'm here, I'll mention that I had problems with the screen brightness not adjusting, and I added the following file: /usr/share/X11/xorg.conf.d/20-intel.conf:

Section "Device"
Identifier "card0"
Driver "intel"
Option "Backlight" "intel_backlight"
BusID "PCI:0:2:0"

EndSection
1
  • @Whirlynerd says: "For the first part, you no longer need to do the blacklist workaround if you update the BIOS to version AO3 (confirmed on model 3147). To get the backlight controls working, adding the 20-intel.conf file as described above worked perfect. Thanks!" – MadMike Jan 31 '15 at 9:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.